FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 06-01-2008, 12:04 PM
Ralf Mardorf
 
Default "Upgraded 2.1rc" to "Lenny" - Reperation steps 1 to 4

This is what I call "standard" repositories without backports
(because the backports are disabled now and all the time during the
upgrade):



[x] deb http://apt.64studio.com/64studio/stable/* 64studio****** main

[x] deb http://ftp.debian.org/debian/************ etch********** main
contrib non-free

[x] deb http://security.debian.org/************** etch/updates** main

[x] deb http://apt.64studio.com/64studio/testing/ 64studio****** main

[ ] deb http://apt.64studio.com/backports/******* etch-backports main



This is what I call the cinelerra repositories (disabled at the moment):



[ ] deb http://www.debian-multimedia.org/******** etch********** main

[ ] deb http://apt.harleystudio.co.za/*********** etch********** main



Last but not least the Lenny repository (enabled at the moment):



[x] deb http://ftp.de.debian.org/debian/********* lenny********* main



I'll go on with the repositories enabled and disabled like above. The
package information is reloaded. I only will use Synaptic.



*First step*



I'll repair the broken KDE and install tork.



Maybe the howto is crap for me, because I'm also using KDE.



Done:


Commit Log for Sun Jun* 1 13:32:58 2008





Removed the following packages:

audacious-plugins-dev

bluez-cups

cupsys

evolution-data-server

libcurl3-gnutls-dev

libldap2

libpt-1.10.0

libpt-plugins-alsa

libpt-plugins-avc

libpt-plugins-dc

libpt-plugins-oss

libpt-plugins-v4l2

libsasl2



Upgraded the following packages:

akregator (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

artsbuilder (4:3.5.5-2) to 4:3.5.9-1

atlantik (4:3.5.5-1) to 4:3.5.9-1

atlantikdesigner (4:3.5.5-1) to 4:3.5.9-1

audacious (1.2.2-4) to 1.5.0-2

audacious-dev (1.2.2-4) to 1.5.0-2

audacious-plugins (1.2.5-1) to 1.5.0-2

audacious-plugins-extra (1.2.5-1) to 1.5.0-2

bzip2 (1.0.3-6) to 1.0.5-0.1

dirmngr (0.9.6-1+b1) to 1.0.1-3

gconf2 (2.16.1-1) to 2.22.0-1

gconf2-common (2.16.1-1) to 2.22.0-1

gnupg (1.4.6-2) to 1.4.6-2.2

gnupg2 (2.0.0-5.2) to 2.0.9-2

kaddressbook (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kaddressbook-plugins (4:3.5.5-1) to 4:3.5.9-1

kalarm (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kandy (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kappfinder (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

karm (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kate (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

kate-plugins (4:3.5.5-1) to 4:3.5.9-1

kdeaddons-kfile-plugins (4:3.5.5-1) to 4:3.5.9-1

kdepasswd (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

kdepim-kfile-plugins (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kdepim-kio-plugins (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kdepim-kresources (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kdepim-wizards (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kdeprint (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

kfind (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

khelpcenter (4:3.5.5a.dfsg.1-6etch2) to 4:4.0.0.really.3.5.9.dfsg.1-2+b1

kicker-applets (4:3.5.5-1) to 4:3.5.9-1

kitchensync (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kleopatra (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

klipper (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

kmenuedit (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

knewsticker-scripts (4:3.5.5-1) to 4:3.5.9-1

knode (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

knotes (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

konqueror-nsplugins (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

konsole (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

konsolekalendar (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kontact (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

korganizer (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kpager (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

kpilot (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

ksig (4:3.5.5-1) to 4:3.5.9-1

ksmserver (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

ksysguard (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

ksysguardd (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

ktip (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

ktnef (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

kwin (4:3.5.5a.dfsg.1-6etch2) to 4:3.5.9.dfsg.1-2+b1

libacl1 (2.2.41-1) to 2.2.45-1

libaspell15 (0.60.4-4) to 0.60.5-2.2

libavahi-qt3-1 (0.6.16-3etch1) to 0.6.22-3

libbluetooth2 (3.7-1) to 3.30-1

libbz2-1.0 (1.0.3-6) to 1.0.5-0.1

libcurl3-gnutls (7.15.5-1etch1) to 7.18.1-1

libfam0 (2.7.0-12) to 2.7.0-13.2

libgconf2-4 (2.16.1-1) to 2.22.0-1

libgpgme11 (1.1.2-5) to 1.1.6-2

libindex0 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libkdegames1 (4:3.5.5-1) to 4:3.5.9-1

libkgantt0 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libkleopatra1 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libkmime2 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libkpimexchange1 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libkpimidentities1 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libksba8 (1.0.0-1) to 1.0.3-1

libksieve0 (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

liblcms1 (1.15-1) to 1.16-10

liblua50 (5.0.3-2) to 5.0.3-3

liblualib50 (5.0.3-2) to 5.0.3-3

libmimelib1c2a (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

libmms0 (0.3-2) to 0.4-2

libpth20 (2.0.7-6) to 2.0.7-10

libsasl2-2 (2.1.22.dfsg1-8) to 2.1.22.dfsg1-20

libsasl2-modules (2.1.22.dfsg1-8) to 2.1.22.dfsg1-20

libsmbclient (3.0.24-6etch10) to 1:3.0.28a-3

libvorbis-dev (1.1.2.dfsg-1.3) to 1.2.0.dfsg-3.1

libvorbis0a (1.1.2.dfsg-1.3) to 1.2.0.dfsg-3.1

libvorbisenc2 (1.1.2.dfsg-1.3) to 1.2.0.dfsg-3.1

libvorbisfile3 (1.1.2.dfsg-1.3) to 1.2.0.dfsg-3.1

libxmu6 (1:1.0.2-2) to 2:1.0.4-1

libxslt1.1 (1.1.22-1~bpo.1) to 1.1.24-1

networkstatus (4:3.5.5.dfsg.1-6) to 4:3.5.9-2

noatun (4:3.5.5-2) to 4:3.5.9-1

noatun-plugins (4:3.5.5-1) to 4:3.5.9-1

samba (3.0.24-6etch10) to 1:3.0.28a-3

samba-common (3.0.24-6etch10) to 1:3.0.28a-3

sudo-ldap (1.6.8p12-4) to 1.6.9p15-2



Installed the following packages:

autotools-dev (20080123.1)

dpatch (2.0.29)

htdig (1:3.2.0b6-6)

kde (5:48)

kde-core (5:48)

kdeaddons (4:3.5.9-1)

kdebase (4:3.5.9.dfsg.1-2)

kdebase-kio-plugins (4:3.5.9.dfsg.1-2+b1)

kdelibs4-dev (4:3.5.9.dfsg.1-4)

kdepim (4:3.5.9-2)

kdepim-dev (4:3.5.9-2)

kmail (4:3.5.9-2)

kmailcvt (4:3.5.9-2)

konq-plugins (4:3.5.9-1)

konqueror (4:3.5.9.dfsg.1-2+b1)

korn (4:3.5.9-2)

libacl1-dev (2.2.45-1)

libart-2.0-dev (2.3.20-2)

libarts1-dev (1.5.9-2)

libaspell-dev (0.60.5-2.2)

libattr1-dev (1:2.4.41-1)

libaudclient1 (1.5.0-2)

libaudid3tag1 (1.5.0-2)

libaudio-dev (1.9.1-2)

libavahi-qt3-dev (0.6.22-3)

libbinio1ldbl (1.4-9)

libbz2-dev (1.0.5-0.1)

libcddb2 (1.2.1-1)

libcdio-cdda0 (0.78.2+dfsg1-2.1)

libcdio7 (0.78.2+dfsg1-2.1)

libcupsys2-dev (1.3.7-5)

libdb4.6++ (4.6.21-6)

libfam-dev (2.7.0-13.2)

libilmbase-dev (1.0.1-2)

libimlib2 (1.4.0-1)

libjasper-dev (1.900.1-4)

libjpeg62-dev (6b-14)

libkcal2-dev (4:3.5.9-2)

libkdepim1-dev (4:3.5.9-2)

libkgantt0-dev (4:3.5.9-2)

libkleopatra1-dev (4:3.5.9-2)

libkpimexchange1-dev (4:3.5.9-2)

libksieve0-dev (4:3.5.9-2)

libktnef1-dev (4:3.5.9-2)

liblcms1-dev (1.16-10)

libldap-2.4-2 (2.4.7-6.3+b1)

liblua50-dev (5.0.3-3)

liblualib50-dev (5.0.3-3)

libmad0-dev (0.15.1b-3)

libmcs-dev (0.7.0-1)

libmcs1 (0.7.0-1)

libmimelib1-dev (4:3.5.9-2)

libmms-dev (0.4-2)

libmng-dev (1.0.9-1)

libmowgli-dev (0.6.1-1)

libmowgli1 (0.6.1-1)

libmtp7 (0.2.6.1-2)

libneon27-gnutls (0.28.2-2)

libopenexr-dev (1.6.1-3)

libpcre3-dev (7.4-1)

libpcrecpp0 (7.4-1)

libqt3-headers (3:3.3.8b-5)

libqt3-mt-dev (3:3.3.8b-5)

libsasl2-dev (2.1.22.dfsg1-20)

libssl-dev (0.9.8g-10)

libtiff4-dev (3.8.2-8)

libtiffxx0c2 (3.8.2-8)

libwavpack-dev (4.41.0-2)

libxmu-dev (2:1.0.4-1)

libxmu-headers (2:1.0.4-1)

libxslt1-dev (1.1.24-1)

lockfile-progs (0.1.11-0.1)

lua50 (5.0.3-3)

qt3-dev-tools (3:3.3.8b-5)

tork (0.28-1)


*Second step*



I'll disable the repository for Lenny, reload package information and
reinstall, resp. install:


exim4, exim4-base, exim4-config, exim4-daemon-light, mailx, mutt

The "exim"s and mailx are the same versions and mutt isn't installed.

Done:

Commit Log for Sun Jun* 1 13:47:04 2008





Installed the following packages:

mutt (1.5.13-1.1etch1)



Reinstalled the following packages:

exim4 (4.63-17)

exim4-base (4.63-17)

exim4-config (4.63-17)

exim4-daemon-light (4.63-17)

mailx (1:8.1.2-0.20050715cvs-1)


*Third step*



I'll take a look at /etc/security/limits.conf. It's still fine.

I'll take a look at /etc/modprobe.d/alsa-base. The last lines are still
fine, that should mean that it's fine at all.

I'll take a look, if I'm member of the group audio.

spinymouse@64studio:~$ groups

spinymouse adm disk dialout cdrom floppy audio video plugdev netdev
stb-admin powerdev scanner camera

I'll check which kernels are installed. I'm in

spinymouse@64studio:~$ uname -r

2.6.18-6-amd64



Installed are:



linux-image-2.6.21-1-multimedia-amd64 2.6.21-2

linux-image-2.6-amd64**************** 2.6.21-2



There are all headers for the multimedia-kernel installed.

There are no transition packages installed and I won't install them.

I'll install the headers for the "normal" kernel later, when I'm going
to test the proprietary ATI driver again.



*Fourth step*



I'll reboot the system. I'll boot into the multimedia-kernel.



Cheers,

Ralf




_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 12:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org