FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 05-03-2010, 06:22 AM
Ralf Mardorf
 
Default Qtractor svn for 64 Studio 3.3 alpha

How to get the full featured latest Qtractor, excepted of JACK Session
support [1]

Hi

I focus special attention on latest versions of LV2 and Rubber Band.
Fortunately LV2 is up to date, unfortunately Rubber Band isn't.
Rui build packages for Hardy and Intrepid, but we do need packages for
Karmic. Take a look at the comparisons [2], there shouldn't be an issue
when installing the Intrepid versions.

Make sure that your 64 Studio 3.3 alpha is upgraded. I attached the
repositories I used [3].

The Rubber Band packages for Intrepid are available at
http://www.rncbc.org/jack/ . First run

$ su root -c "adduser your_username src"

Then you need to log out, Menu > Logout > Logout and to log in again,
the user should be added to the group src, check it by running

$ groups

Then run

$ cd /usr/src
$ mkdir rubberband-1.4
$ cd rubberband-1.4

If you've got 64 Studio 3.3 alpha amd64 installed run

$ studio=amd64

or if you've got the i386 version installed run

$ studio=i386

then for both versions go on with running

$ wget http://www.rncbc.org/jack/librubberband1_1.4.0-1.rncbc.ubuntu904_
${studio}.deb
$ wget
http://www.rncbc.org/jack/librubberband-dev_1.4.0-1.rncbc.ubuntu904_
${studio}.deb
$ su root -c "apt-get update"
$ su root -c "apt-get install equivs"
$ equivs-control librubberband2

Use any editor, e.g. gedit to edit the generated librubberband2 file.
$ gedit librubberband2
### Commented entries have reasonable defaults.
### Uncomment to edit them.
Section: misc
Priority: optional
Standards-Version: 3.6.2

Package: librubberband2
Version: 1.4.0
# Maintainer: Your Name <yourname@example.com>
# Pre-Depends: <comma-separated list of packages>
Depends: librubberband1
# Recommends: <comma-separated list of packages>
# Suggests: <comma-separated list of packages>
# Provides: <comma-separated list of packages>
# Replaces: <comma-separated list of packages>
Architecture: all
# Copyright: <copyright file; defaults to GPL2>
# Changelog: <changelog file; defaults to a generic changelog>
# Readme: <README.Debian file; defaults to a generic one>
# Extra-Files: <comma-separated list of additional files for the
doc directory>
Description: librubberband2 dummy package
$ equivs-build librubberband2
$ rm librubberband2 librubberband2~
$ su root -c "dpkg -i --force-overwrite
librubberband1_1.4.0-1.rncbc.ubuntu904_${studio}.deb
librubberband2_1.4.0_all.deb librubberband-dev_1.4.0-1.rncbc.ubuntu904_
${studio}.deb"

Make sure that the packages g++, debhelper, fakeroot, subversion,
autoconf2.13 and what ever is needed to get the source code, to compile
and build the qtractor package are installed, in addition you need the
software requirements for build and runtime that are needed by Qtractor.
To get them run

$ cd ..
$ su root -c "apt-get update"
$ su root -c "apt-get install qtractor libqt4-dev libjack-dev
libasound2-dev libsndfile1-dev ladspa-sdk libvorbis-dev libmad0-dev
libsamplerate0-dev liblo0-dev libslv2-dev lv2core dssi-dev libslv2-dev"

If you like to have the optional VST support you need to get the headers
by VST SDK from Steinberg's Virtual Studio Technology at
http://www.steinberg.net/ , or you copy them from another install, if
you once downloaded those header files.

$ su root -c
"cp /path/were/the/two/needed/headers/are/aeffect.h /usr/local/include"
$ su root -c
"cp /path/were/the/two/needed/headers/are/aeffectx.h /usr/local/include"

To get latest trunk from svn, to build and package qtractor run

$ svn co https://qtractor.svn.sourceforge.net/svnroot/qtractor/trunk
qtractor-svn
$ cd qtractor-svn
$ make -f Makefile.svn
$ ./configure
[snip]
Build target . . . . . . . . . . . . . . . . . . .: release

JACK Audio Connection Kit support . . . . . . . .: yes
ALSA MIDI Sequencer support . . . . . . . . . . .: yes
General audio file support (libsndfile) . . . . .: yes
Ogg Vorbis audio file support (libvorbis) . . . .: yes
MPEG-1 Audio Layer 3 file support (libmad) . . . .: yes
Sample-rate conversion support (libsamplerate) . .: yes
Pitch-shifting support (librubberband) . . . . . .: yes
OSC service support (liblo) . . . . . . . . . . .: yes
IEEE 32bit float optimizations . . . . . . . . . .: yes
SSE optimization support (x86) . . . . . . . . . .: yes
LADSPA Plug-in support . . . . . . . . . . . . . .: yes
DSSI Plug-in support . . . . . . . . . . . . . . .: yes
VST Plug-in support . . . . . . . . . . . . . . .: yes
LV2 Plug-in support (libslv2) . . . . . . . . . .: yes
LV2 Plug-in Event/MIDI support . . . . . . . . . .: yes
LV2 Plug-in External UI support . . . . . . . . .: yes
LV2 Plug-in Save/Restore support . . . . . . . . .: yes

JACK Session support (EXPERIMENTAL) . . . . . . .: no

X11 Unique/Single instance . . . . . . . . . . . .: no
XInitThreads() support (DANGEROUS) . . . . . . . .: no
Gradient eye-candy . . . . . . . . . . . . . . . .: yes
Debugger stack-trace (gdb) . . . . . . . . . . . .: no

Install prefix . . . . . . . . . . . . . . . . . .: /usr/local

Now type 'make', followed by 'make install' as root.

Note that there isn't the need to run './configure', before you run
'fakeroot dpkg-buildpackage'.
Don't type 'make' and don't type 'make install', but instead run

$ fakeroot dpkg-buildpackage
$ su root -c "make clean"


For the next steps change the version in the file names to the version
you build.

$
rm ../qtractor_0.4.5-1_amd64.changes ../qtractor_0.4.5-1.dsc ../qtractor_0.4.5-1.tar.gz
$ mv ../qtractor_0.4.5-1_amd64.deb ./

Replace the outdated Karmic's Qtractor version 0.4.2-0ubuntu1 by the
current version, by running

$ su root -c "dpkg -i qtractor_0.4.5-1_amd64.deb"

If you run 'su root -c "checkinstall"' instead of 'fakeroot
dpkg-buildpackage' + 'dpkg -i', you're able to add the complete version,
to the package, currently 0.4.5.1557+, this will enable that you could
switch between different versions from svn, the disadvantage would be,
that for those packages information, that you don't need, isn't added
automatically, e.g. there will be no dependencies automatically listed.
You could run

$ mv qtractor_0.4.5-1_amd64.deb qtractor_0.4.5-1557_amd64.deb

but this only effects the file name .



Cheers!

Ralf

[1]
> jack session
> word used in the car business when a customer "jacks you off" and
> wastes your time and doesnt buy a car. person 1: "do you got a deal
> with those people"?
> person 2: " nah, that was a total jack session"!



[2]
A comparison between ahead librubberband2 1.2-1ubuntu1 (Karmic) and
below it librubberband2 1.4.0-1.rncbc.ubuntu904
Depends
libc6 (>= 2.4)
libc6 (>= 2.4)
libfftw3-3
libfftw3-3
libgcc1 (>=1:4.1.1)
libgcc1 (>=1:4.1.1)
libsamplerate0
libsamplerate0
libstdc++6 (>=4.4.0)
libstdc++6 (>=4.2.1)
Installed Files (documents are ignored)
/usr/lib/librubberband.so.2.0.0
/usr/lib/librubberband.so.2.1.0
/usr/lib/librubberband.so.2
/usr/lib/librubberband.so.2

A comparison between ahead librubberband-dev 1.2-1ubuntu1 (Karmic) and
below it librubberband-dev 1.4.0-1.rncbc.ubuntu904
Depends
librubberband2 (=1.2-1unbuntu1)
librubberband1 (=1.4.0-1.rncbc.ubuntu904)
Installed files (documents are ignored)
/usr/include/rubberband/rubberband-c.h
/usr/include/rubberband/rubberband-c.h
/usr/include/rubberband/RubberBandStretcher.h
/usr/include/rubberband/RubberBandStretcher.h
/usr/lib/librubberband.a
/usr/lib/librubberband.a
/usr/lib/pkgconfig/rubberband.pc
/usr/lib/pkgconfig/rubberband.pc
/usr/lib/librubberband.so
/usr/lib/librubberband.so

[3]
$ cat /etc/apt/sources.list
deb http://cz.archive.ubuntu.com/ubuntu/ karmic main
deb http://archive.ubuntu.com/ubuntu/ karmic main restricted universe
multiverse
deb http://it.archive.ubuntu.com/ubuntu/ karmic-updates main restricted
universe multiverse
deb http://security.ubuntu.com/ubuntu/ karmic-security restricted main
multiverse universe
deb http://archive.ubuntu.com/ubuntu/ karmic-backports restricted main
multiverse universe
deb http://apt.64studio.com/backports/ karmic-backports main
deb http://ppa.launchpad.net/shutter/ppa/ubuntu/ karmic main
# deb http://packages.medibuntu.org/ karmic free non-free

[The Qtractor homepage]
http://qtractor.sourceforge.net/qtractor-index.html

[To be continued ...]
- because of the JACK Session issue (I still need information)
- because of translations (Something changed, I need information myself)
- because where to change the version/ revision for the package
managment when using 'fakeroot dpkg-buildpackage' (a quick --help
didn't answer this)
- HOWTO update from svn, by using eSvn (the way I usually do updates)
- because I had no time to test Qtractor yet, anyway, it started.


_______________________________________________
64studio-users mailing list
64studio-users@lists.64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 01:04 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org