FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 04-26-2010, 03:49 PM
Ralf Mardorf
 
Default NVIDIA issue for 64 Studio 3.3 alpha amd64

Hi

the NVIDIA issue possibly is solved.

Now there's a new issue, Google Earth doesn't build completely [1]. Any
ideas, but a 32-bit chroot?

Notes about xorg.conf

I tested two xorg.confs, both cause the wanted 1152x864@90Hz always for
the nv and for the nvidia driver, but I need to disable the virtual
resolution.
root@64studio:/etc/X11# ls -al xorg.conf*
-rw-r--r-- 1 root root 1286 2010-04-26 14:39 xorg.conf
-rw-r--r-- 1 root root 1286 2010-04-26 14:39
xorg.conf_basedon_studio3.3-alpha
-rw-r--r-- 1 root root 1192 2010-04-26 14:12
xorg.conf_similar2studio3.0-beta3

When using the xorg.conf_similar2studio3.0-beta3 [2] the system gets
frozen after a while, when using both the nv and the nvidia driver, but
I noticed that there might be bad entries for the modules, OTOH I had
this issue for other xorg.confs, not trying to load those modules (that
might belong to an ATI Radeon) too.
When using the xorg.conf_basedon_studio3.3-alpha (the current xorg.conf)
[3] I didn't made a long test for the nv driver, but I'm working for a
long time using the nvidia driver without running into issues, hence I
guess everything is ok now.

Unfortunately the frequencies are always 81.9 KHz 89.9 Hz, while at
least h/v positions between nv and nvidia driver differ, so multi-sync
monitors will get trouble to restore both 64 Studio 3.0-beta3 using the
nv driver and the alpha version using the nvidia driver. For Suse it's
possible to change h/v positions by Sax, by the software, instead of
changing it by adjusting the monitor. Is there an application for Ubuntu
able to do the same?

The alpha has one advantage. While for Suse using the nvidia driver, I
need to stop the first session after the startup by double push Ctrl +
Alt + Backspace, because the first session has X trouble, but any
following session is absolutely ok and while for 3.0-beta3 using the nv
driver, X is broken for GDM, by fortune it's always possible to log in,
for the alpha GDM and LXDE are always ok using both the nv and the
nvidia driver.

Cheers!

Ralf

PS: Perhaps replies regarding to the Google Earth issue should be sent
to the users list only.
Okay, I didn't solve the libpixbufloader-png.so issue, but because I run
# getlibs -p gvfs I expected the gio/modules issue to be solved.

[1]
spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
./setup.sh: 284: setup.data/bin/Linux/amd64/setup.gtk2: not found
./setup.sh: 299: setup.data/bin/Linux/amd64/setup.gtk: not found
The setup program seems to have failed on amd64

Fatal error, installer failed to run at all!

root@64studio:/home/spinymouse/Desktop# getlibs -p libgtk2.0-0
libgtk2.0-bin libgtk2.0-common libgtk2.0-dev
root@64studio:/home/spinymouse/Desktop# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
IT DID BUILD, BUT THE WINDOW WERE THE EARTH SHOULD BE IS BLACK.

spinymouse@64studio:~/google-earth$ ldd googleearth-bin
linux-gate.so.1 => (0xf7f60000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7f2a000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7e38000)
libQtCore.so.4 => /usr/lib32/libQtCore.so.4 (0xf7c05000)
libQtGui.so.4 => /usr/lib32/libQtGui.so.4 (0xf7267000)
libQtNetwork.so.4 => /usr/lib32/libQtNetwork.so.4 (0xf7151000)
libQtWebKit.so.4 => not found
libgoogleearth_lib.so => not found
libm.so.6 => /lib32/libm.so.6 (0xf712a000)
libc.so.6 => /lib32/libc.so.6 (0xf6fe5000)
/lib/ld-linux.so.2 (0xf7f61000)
libbase.so => not found
libgeobase.so => not found
libz.so.1 => /usr/lib32/libz.so.1 (0xf6fce000)
libgthread-2.0.so.0 => /usr/lib32/libgthread-2.0.so.0 (0xf6fc8000)
librt.so.1 => /lib32/librt.so.1 (0xf6fbf000)
libglib-2.0.so.0 => /lib32/libglib-2.0.so.0 (0xf6f09000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf6eef000)
libdl.so.2 => /lib32/libdl.so.2 (0xf6eeb000)
libaudio.so.2 => /usr/lib32/libaudio.so.2 (0xf6ed1000)
libpng12.so.0 => /usr/lib32/libpng12.so.0 (0xf6ea9000)
libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf6e2a000)
libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf6deb000)
libSM.so.6 => /usr/lib32/libSM.so.6 (0xf6de2000)
libICE.so.6 => /usr/lib32/libICE.so.6 (0xf6dc7000)
libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf6dbd000)
libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf6d90000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf6d80000)
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf6c50000)
libpcre.so.3 => /lib32/libpcre.so.3 (0xf6c1f000)
libXt.so.6 => /usr/lib32/libXt.so.6 (0xf6bcc000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf6bc8000)
libuuid.so.1 => /lib32/libuuid.so.1 (0xf6bc3000)
libexpat.so.1 => /lib32/libexpat.so.1 (0xf6b9b000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf6b7d000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf6b78000)

root@64studio:/home/spinymouse/google-earth#
getlibs /home/spinymouse/google-earth/googleearth-bin
libQtWebKit.so.4: libqt4-webkit
No match for libgoogleearth_lib.so
libbase.so: libdeal.ii-dev
No match for libgeobase.so
The following i386 packages will be installed:
libdeal.ii-dev
libqt4-webkit
Continue [Y/n]? Y
[snip]

root@64studio:/home/spinymouse/Desktop# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
loki_setup: Suspect size value for option option

/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class:
ELFCLASS64
Failed to load
module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-cancel' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-media-forward-ltr' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-execute' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon 'gtk-quit'
for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64
loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
spinymouse@64studio:~/google-earth$ ldd googleearth-bin | grep not
found
libgoogleearth_lib.so => not found
libbase.so => not found
libgeobase.so => not found

root@64studio:/home/spinymouse/google-earth# getlibs -p gvfs
The following i386 packages will be installed: gvfs
Continue [Y/n]? Y
Downloading ...
Installing libraries ...
root@64studio:/home/spinymouse/google-earth# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
loki_setup: Suspect size value for option option

/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class:
ELFCLASS64
Failed to load
module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-cancel' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-media-forward-ltr' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-execute' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon 'gtk-quit'
for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64
loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
spinymouse@64studio:~/Desktop$ ldd ../google-earth/googleearth-bin |
grep not found
libgoogleearth_lib.so => not found
libbase.so => not found
libgeobase.so => not found

[2] & [3]
root@64studio:/etc/X11# cat xorg.conf_similar2studio3.0-beta3
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "ro"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "GeForce 7300 SE"
#Driver "nv"
Driver "nvidia"
Screen 0
Option "MergedFB" "off"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 29-98
Identifier "Configured Monitor"
Modelname "Plug 'n' Play"
Vendorname "Plug 'n' Play"
VertRefresh 50-120
modeline "1152x864" 128.42 1152 1232 1360 1568 864 865 868 910
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
#Virtual 3840 1200
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
root@64studio:/etc/X11# cat xorg.conf_basedon_studio3.3-alpha
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 29-98
Identifier "Monitor0"
Modelname "Plug 'n' Play"
Vendorname "Plug 'n' Play"
VertRefresh 50-120
modeline "1152x864" 128.42 1152 1232 1360 1568 864 865 868 910
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
#Driver "nv"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
#Virtual 3840 1200
EndSubSection
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
EndSection

_______________________________________________
64studio-users mailing list
64studio-users@lists.64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 04-26-2010, 03:49 PM
Ralf Mardorf
 
Default NVIDIA issue for 64 Studio 3.3 alpha amd64

Hi

the NVIDIA issue possibly is solved.

Now there's a new issue, Google Earth doesn't build completely [1]. Any
ideas, but a 32-bit chroot?

Notes about xorg.conf

I tested two xorg.confs, both cause the wanted 1152x864@90Hz always for
the nv and for the nvidia driver, but I need to disable the virtual
resolution.
root@64studio:/etc/X11# ls -al xorg.conf*
-rw-r--r-- 1 root root 1286 2010-04-26 14:39 xorg.conf
-rw-r--r-- 1 root root 1286 2010-04-26 14:39
xorg.conf_basedon_studio3.3-alpha
-rw-r--r-- 1 root root 1192 2010-04-26 14:12
xorg.conf_similar2studio3.0-beta3

When using the xorg.conf_similar2studio3.0-beta3 [2] the system gets
frozen after a while, when using both the nv and the nvidia driver, but
I noticed that there might be bad entries for the modules, OTOH I had
this issue for other xorg.confs, not trying to load those modules (that
might belong to an ATI Radeon) too.
When using the xorg.conf_basedon_studio3.3-alpha (the current xorg.conf)
[3] I didn't made a long test for the nv driver, but I'm working for a
long time using the nvidia driver without running into issues, hence I
guess everything is ok now.

Unfortunately the frequencies are always 81.9 KHz 89.9 Hz, while at
least h/v positions between nv and nvidia driver differ, so multi-sync
monitors will get trouble to restore both 64 Studio 3.0-beta3 using the
nv driver and the alpha version using the nvidia driver. For Suse it's
possible to change h/v positions by Sax, by the software, instead of
changing it by adjusting the monitor. Is there an application for Ubuntu
able to do the same?

The alpha has one advantage. While for Suse using the nvidia driver, I
need to stop the first session after the startup by double push Ctrl +
Alt + Backspace, because the first session has X trouble, but any
following session is absolutely ok and while for 3.0-beta3 using the nv
driver, X is broken for GDM, by fortune it's always possible to log in,
for the alpha GDM and LXDE are always ok using both the nv and the
nvidia driver.

Cheers!

Ralf

PS: Perhaps replies regarding to the Google Earth issue should be sent
to the users list only.
Okay, I didn't solve the libpixbufloader-png.so issue, but because I run
# getlibs -p gvfs I expected the gio/modules issue to be solved.

[1]
spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
./setup.sh: 284: setup.data/bin/Linux/amd64/setup.gtk2: not found
./setup.sh: 299: setup.data/bin/Linux/amd64/setup.gtk: not found
The setup program seems to have failed on amd64

Fatal error, installer failed to run at all!

root@64studio:/home/spinymouse/Desktop# getlibs -p libgtk2.0-0
libgtk2.0-bin libgtk2.0-common libgtk2.0-dev
root@64studio:/home/spinymouse/Desktop# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
IT DID BUILD, BUT THE WINDOW WERE THE EARTH SHOULD BE IS BLACK.

spinymouse@64studio:~/google-earth$ ldd googleearth-bin
linux-gate.so.1 => (0xf7f60000)
libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf7f2a000)
libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf7e38000)
libQtCore.so.4 => /usr/lib32/libQtCore.so.4 (0xf7c05000)
libQtGui.so.4 => /usr/lib32/libQtGui.so.4 (0xf7267000)
libQtNetwork.so.4 => /usr/lib32/libQtNetwork.so.4 (0xf7151000)
libQtWebKit.so.4 => not found
libgoogleearth_lib.so => not found
libm.so.6 => /lib32/libm.so.6 (0xf712a000)
libc.so.6 => /lib32/libc.so.6 (0xf6fe5000)
/lib/ld-linux.so.2 (0xf7f61000)
libbase.so => not found
libgeobase.so => not found
libz.so.1 => /usr/lib32/libz.so.1 (0xf6fce000)
libgthread-2.0.so.0 => /usr/lib32/libgthread-2.0.so.0 (0xf6fc8000)
librt.so.1 => /lib32/librt.so.1 (0xf6fbf000)
libglib-2.0.so.0 => /lib32/libglib-2.0.so.0 (0xf6f09000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf6eef000)
libdl.so.2 => /lib32/libdl.so.2 (0xf6eeb000)
libaudio.so.2 => /usr/lib32/libaudio.so.2 (0xf6ed1000)
libpng12.so.0 => /usr/lib32/libpng12.so.0 (0xf6ea9000)
libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf6e2a000)
libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf6deb000)
libSM.so.6 => /usr/lib32/libSM.so.6 (0xf6de2000)
libICE.so.6 => /usr/lib32/libICE.so.6 (0xf6dc7000)
libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf6dbd000)
libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf6d90000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf6d80000)
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf6c50000)
libpcre.so.3 => /lib32/libpcre.so.3 (0xf6c1f000)
libXt.so.6 => /usr/lib32/libXt.so.6 (0xf6bcc000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf6bc8000)
libuuid.so.1 => /lib32/libuuid.so.1 (0xf6bc3000)
libexpat.so.1 => /lib32/libexpat.so.1 (0xf6b9b000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf6b7d000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf6b78000)

root@64studio:/home/spinymouse/google-earth#
getlibs /home/spinymouse/google-earth/googleearth-bin
libQtWebKit.so.4: libqt4-webkit
No match for libgoogleearth_lib.so
libbase.so: libdeal.ii-dev
No match for libgeobase.so
The following i386 packages will be installed:
libdeal.ii-dev
libqt4-webkit
Continue [Y/n]? Y
[snip]

root@64studio:/home/spinymouse/Desktop# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
loki_setup: Suspect size value for option option

/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class:
ELFCLASS64
Failed to load
module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-cancel' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-media-forward-ltr' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-execute' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon 'gtk-quit'
for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10266): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64
loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
spinymouse@64studio:~/google-earth$ ldd googleearth-bin | grep not
found
libgoogleearth_lib.so => not found
libbase.so => not found
libgeobase.so => not found

root@64studio:/home/spinymouse/google-earth# getlibs -p gvfs
The following i386 packages will be installed: gvfs
Continue [Y/n]? Y
Downloading ...
Installing libraries ...
root@64studio:/home/spinymouse/google-earth# ldconfig

spinymouse@64studio:~/Desktop$ ./GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux
5.1.3533.1731..................................... ..........................
loki_setup: Suspect size value for option option

/usr/lib/gio/modules/libgiogconf.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgiogconf.so
/usr/lib/gio/modules/libgioremote-volume-monitor.so: wrong ELF class:
ELFCLASS64
Failed to load
module: /usr/lib/gio/modules/libgioremote-volume-monitor.so
/usr/lib/gio/modules/libgvfsdbus.so: wrong ELF class: ELFCLASS64
Failed to load module: /usr/lib/gio/modules/libgvfsdbus.so

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-cancel' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-media-forward-ltr' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-execute' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon 'gtk-quit'
for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64

(setup.gtk2:10807): Gtk-WARNING **: Error loading theme icon
'gtk-dialog-info' for stock: Unable to load image-loading
module: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: wrong ELF class: ELFCLASS64
loki_setup: Suspect size value for option option

Installing mimetypes...
Installing desktop menu entries...
Installing desktop icon...
spinymouse@64studio:~/Desktop$ ldd ../google-earth/googleearth-bin |
grep not found
libgoogleearth_lib.so => not found
libbase.so => not found
libgeobase.so => not found

[2] & [3]
root@64studio:/etc/X11# cat xorg.conf_similar2studio3.0-beta3
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "ro"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "GeForce 7300 SE"
#Driver "nv"
Driver "nvidia"
Screen 0
Option "MergedFB" "off"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 29-98
Identifier "Configured Monitor"
Modelname "Plug 'n' Play"
Vendorname "Plug 'n' Play"
VertRefresh 50-120
modeline "1152x864" 128.42 1152 1232 1360 1568 864 865 868 910
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
#Virtual 3840 1200
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection

Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection
root@64studio:/etc/X11# cat xorg.conf_basedon_studio3.3-alpha
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
DisplaySize 305 230
HorizSync 29-98
Identifier "Monitor0"
Modelname "Plug 'n' Play"
Vendorname "Plug 'n' Play"
VertRefresh 50-120
modeline "1152x864" 128.42 1152 1232 1360 1568 864 865 868 910
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
#Driver "nv"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
#Virtual 3840 1200
EndSubSection
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
EndSection

_______________________________________________
64studio-devel mailing list
64studio-devel@lists.64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 

Thread Tools




All times are GMT. The time now is 12:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org