Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   64 Studio User (http://www.linux-archive.org/64-studio-user/)
-   -   Installer information for GeForce 7200 and 7300 (http://www.linux-archive.org/64-studio-user/351481-installer-information-geforce-7200-7300-a.html)

Ralf Mardorf 04-04-2010 02:59 PM

Installer information for GeForce 7200 and 7300
 
I subscribed to the NVIDIA Linux forum. If somebody is interested to do
the same, I needed to clear private data, such as cookies before I was
able to do it. The message to confirm the registration was moved to
Thunderbird's Trash folder, the folder I'm using for spam, instead of
the Junk folder.

Btw. the GeForce 7300SE seems to be the "same" card as my GeForce 7200GS.

Hopefully there will be some information at

http://www.nvnews.net/vbulletin/showthread.php?t=149703

Cheers!
Ralf

--
Icemouse
Registered User

Join Date: Apr 2010
Posts: 1
NVIDIA installer ignores kernel source path
------------------------------------------------------------------------
Hi,

there are several issues caused by a GeForce 7200GS I bought some days
ago. There are issues when using the xorg FLOSS driver for Suse and for
64 Studio. There are issues when using the proprietary NVIDIA driver for
Suse.
I like to start with one issue. NVIDIA-Linux-x86_64-195.36.15-pkg2.run
isn't able to build a driver for 64 Studio 3.0-beta3, based on Ubuntu Hardy.

The proprietary NVIDIA installer can't build the driver for a self build
kernel-rt, because it doesn't know the kernel source path, btw. it seems
to be that the needed kernel source is provided by the package
linux-headers and not by the package linux-source, at least because of
version.h.

For the self-build kernel-rt on Suse there isn't such an issue, the
installer was able to build the proprietary driver. I can't say if the
driver is completely ok, at least a session started. I zero in on
getting it working for 64 Studio, so at the moment I won't make tests
running Suse.

64 Studio 3.0-beta3 64-bit

$ sudo -i
# cd /lib/modules/$(uname -r)
# ln -s /usr/src/linux-headers-$(uname -r) build
# ln -s /usr/src/linux-headers-$(uname -r) source
# /etc/init.d/gdm stop
$ sudo -i
# cd /usr/src
# export SYSSRC=/usr/src/linux-headers-$(uname -r)
# echo $SYSSRC
# sh ./NVIDIA-Linux* -q --kernel-source=/usr/src/linux-headers-$(uname -r)
# sh ./NVIDIA-Linux* -q

Both times the NVIDIA installer was missing something.

Suse 11.2/11.3 64-bit

> su
# init3
# cd /usr/src
# sh ./NVIDIA-Linux* -q

For Suse there was no problem for the proprietary installer.

The kernel for 64 Studio is $ uname -r 2.6.31.12-rt20.

Any ideas?

Cheers!
Ralf
_______________________________________________
64studio-users mailing list
64studio-users@lists.64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users


All times are GMT. The time now is 03:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.