FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 01-09-2009, 08:14 PM
Jaromír Mikeš
 
Default Installing HOLAP audio plugins in 64 studio 2.1

< � wrote:
< > < <snip>
< > < > missing package was libfltk1.1-dev for my 2.1 64Studio 32bit ech/lenny
< > < > mixed installation.
< > < > Now it is installed and working fine just simple ./configure
< > < >
< > < > Still having troubles on my second machine ... fresh installation of
< > < > 64Studio 3.0 Alpha.
< > < >
< > < > After ./configure I getting errors :
< > < > ./configure: line 17740: syntax error near unexpected token `MODULE,'
< > < > ./configure: line 17740: `PKG_CHECK_MODULES(MODULE, dssi >= 0.4 liblo >=
< > < > 0.12)'
< > < >
< > < > I already asked on [LAU] I will report.
< > < >
< > < You are probably missing the dssi-dev package. The other option is to
< > < disable dssi support. Likely there is a ./configure flag for this.
< > <
< > < Hth,
< >
< > Hello Gustin,
< >
< > I've already succeed install this bundle on one machine with 2.1 64studio
< 32bit etch/lenny system
< > On second machine with 3.0 Alpha realese having this problem.
< > I have dssi-dev installed ... I already disabled this line
< `PKG_CHECK_MODULES(MODULE, < dssi >= 0.4 liblo >= 0.12)'
< > in configure.ac after Josep's (author) advice.
< > and ./configure was running well then.
< > But then there was problem with make ... try the link if you are interested.
< >
< >
< http://lists.linuxaudio.org/pipermail/linux-audio-user/2009-January/057704.html
< >
< > I think some of plugins from this bundle are dependent directly on dssi ...not
< sure... at least exciter I guess.
< > So it is possible just disable dssi ...again ... not sure.
< >
< >
< My next guess is that the problem is the version of gcc is causing
< grief. Ubuntu is pretty aggressive with the version of gcc that they
< ship, especially when compared to Debian stable. Not sure what you can
< do other than looking at the lines where the failures occur and trying
< to figure out if there is something else you could disable.

It looks like it can be problem gcc ... I succeed install this bundle on my 2.1 etch/lenny system what is proving your words about ubuntu/debian.
On my 2.1 etch/lenny system are these versions of gcc 4.1.2 4.2.4. 4.3.2 and licgcc1 4.3.2
On 3.0 Alpha 4.1.2 and 4.2.4 and libgcc1 4.2.4

This bundle is still quite beta ...

I will check what I am able to do with it.

thank you

mira
_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 01-09-2009, 08:24 PM
Tapani Sysimetsä
 
Default Installing HOLAP audio plugins in 64 studio 2.1

Hi,

I updated the how-to for 64 Studio 2.1, new version is below. Thanks to
Mira and Gustin for improvements. I hope you can find a way to install
them also in 64 Studio 3.0.


I posted it to the forum too:
http://64studio.com/forum/8

But when I edited it, it appeared there twice... How can I remove it,
can't find that option?


Tapani




###


Josep Andreu has written a nice set of new DSSI and LADSPA audio
plugins; including exciter, harmonizer, wah, delay, chorus, eq's,
phaser, and (a superb) reverb. Many thanks to him.


”Most of this LADSPA plugins are based on the wonderful ZynAddsubFx
synthesizer (Paul Nasca) set of effects. I allways want to thanks Paul
Nasca for his work because I've been through the entry into the world of
audio programming.” (Josep Andreu)


Below is my how-to for installing those plugins in 64 Studio 2.1,
because I found the installation procedure quite complicated. If you
have any corrections or improvements, please tell.


There's more info on HOLAP's page: http://holap.berlios.de/index.html
and LAU mailing list archive:
http://lalists.stanford.edu/lau/2008/12/0407.html




INSTALLING HOLAP AUDIO PLUGINS IN 64 STUDIO 2.1

* as root:

apt-get install autoconf automake dssi-dev libfltk1.1-dev liblo0-dev cvs

cvs -dserver:anonymous@cvs.holap.berlios.de:/cvsroot/holap login * (no
password needed, just press enter)


cvs -z3 -dserver:anonymous@cvs.holap.berlios.de:/cvsroot/holap co holap

* you will need libtool 2.2.6a-1, which is available in Debian
experimental
* repostories. It did not have any dependencies when I installed it,
only

* one package was needed.

* libtool 2.2.6a-1 for 64-bit:

wget
http://ftp.de.debian.org/debian/pool/main/libt/libtool/libtool_2.2.6a-1_amd64.deb


dpkg -i libtool_2.2.6a-1_amd64.deb

* libtool 2.2.6a-1 for 32-bit:

wget
http://ftp.de.debian.org/debian/pool/main/libt/libtool/libtool_2.2.6a-1_i386.deb


dpkg -i libtool_2.2.6a-1_i386.deb

* Each plugin has to be installed separately. However, if you copy and
* paste all lines below to terminal, you may be lucky to install
them all at

* once. Of course, you can play more safe by copying it line by line...

cd holap
cd exciter
./autogen.sh
./configure
make
make install
make clean
cd ..
cd harmonizer
./autogen.sh
./configure
make
make install
make clean
cd ..
cd harmonizer_l
./autogen.sh
./configure
make
make install
make clean
cd ..
cd musicaldelay
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zynalienwah
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zynchorus
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zyneq3par
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zyneq10band
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zynphaser
./autogen.sh
./configure
make
make install
make clean
cd ..
cd zynreverb
./autogen.sh
./configure
make
make install
make clean
cd ..
cd ..


_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 01-10-2009, 12:49 PM
Jaromír Mikeš
 
Default Installing HOLAP audio plugins in 64 studio 2.1

Hi,


on 3.0 Alpha

not installed
exciter, harmonizer

installed
harmonizer_l, musicaldelay, zynalienwah, zynchorus, zyneq3par, zyneyneq10band, zynphaser, zynreverb

mira


< ----------------------------------------
< Hi,
<
< I updated the how-to for 64 Studio 2.1, new version is below. Thanks to
< Mira and Gustin for improvements. I hope you can find a way to install
< them also in 64 Studio 3.0.
<
< I posted it to the forum too:

< http://64studio.com/forum/8
<
< But when I edited it, it appeared there twice... How can I remove it,
< can't find that option?
<
< Tapani
<
<
<
<
< ###
<
<
< Josep Andreu has written a nice set of new DSSI and LADSPA audio
< plugins; including exciter, harmonizer, wah, delay, chorus, eq's,
< phaser, and (a superb) reverb. Many thanks to him.
<
< ”Most of this LADSPA plugins are based on the wonderful ZynAddsubFx
< synthesizer (Paul Nasca) set of effects. I allways want to thanks Paul
< Nasca for his work because I've been through the entry into the world of
< audio programming.” (Josep Andreu)
<
< Below is my how-to for installing those plugins in 64 Studio 2.1,
< because I found the installation procedure quite complicated. If you
< have any corrections or improvements, please tell.
<
< There's more info on HOLAP's page: http://holap.berlios.de/index.html
< and LAU mailing list archive:
< http://lalists.stanford.edu/lau/2008/12/0407.html
<
<
<
< INSTALLING HOLAP AUDIO PLUGINS IN 64 STUDIO 2.1
<
< * as root:
<
< apt-get install autoconf automake dssi-dev libfltk1.1-dev liblo0-dev cvs
<
< cvs -dserver:anonymous@cvs.holap.berlios.de:/cvsroot/holap login * (no
< password needed, just press enter)
<
< cvs -z3 -dserver:anonymous@cvs.holap.berlios.de:/cvsroot/holap co holap
<
< * you will need libtool 2.2.6a-1, which is available in Debian
< experimental
< * repostories. It did not have any dependencies when I installed it,
< only

< * one package was needed.
<
< * libtool 2.2.6a-1 for 64-bit:
<
< wget
< http://ftp.de.debian.org/debian/pool/main/libt/libtool/libtool_2.2.6a-1_amd64.deb
<
< dpkg -i libtool_2.2.6a-1_amd64.deb
<
< * libtool 2.2.6a-1 for 32-bit:
<
< wget
< http://ftp.de.debian.org/debian/pool/main/libt/libtool/libtool_2.2.6a-1_i386.deb
<
< dpkg -i libtool_2.2.6a-1_i386.deb
<
< * Each plugin has to be installed separately. However, if you copy and
< * paste all lines below to terminal, you may be lucky to install
< them all at

< * once. Of course, you can play more safe by copying it line by line...
<
< cd holap

< cd exciter
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd harmonizer
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd harmonizer_l
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd musicaldelay
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zynalienwah
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zynchorus
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zyneq3par
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zyneq10band
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zynphaser
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd zynreverb
< ./autogen.sh
< ./configure
< make
< make install
< make clean
< cd ..
< cd ..
<
<
< _______________________________________________

< 64studio-users mailing list
< 64studio-users@64studio.com
< http://lists.64studio.com/mailman/listinfo/64studio-users
<
<
<
_______________________________________________

64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 01:38 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org