Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   64 Studio User (http://www.linux-archive.org/64-studio-user/)
-   -   The sync and jitter issue, one issue is solved another isn't solved (http://www.linux-archive.org/64-studio-user/150532-sync-jitter-issue-one-issue-solved-another-isnt-solved.html)

Ralf Mardorf 08-28-2008 09:24 PM

The sync and jitter issue, one issue is solved another isn't solved
 
Hi :)

I tested something for the Jack dev list.

Using this setup

64 Studio 2.1rc1 upgarded to Lenny

spinymouse@64studio:~$ uname -r
2.6.21-1-multimedia-amd64
spinymouse@64studio:~$ jackd -V
jackd version 0.109.2 tmpdir /dev/shm protocol 22
spinymouse@64studio:~$ qjackctl -v
Warning: no locale found: /usr/share/locale/qjackctl_en_US.qm
Qt: 4.4.0
QjackCtl: 0.3.2
spinymouse@64studio:~$ hydrogen -v
0.9.3
spinymouse@64studio:~$ ardour2 -v
Ardour/GTK 2.5
(built using 3525 and GCC version 4.2.4 (Debian 4.2.4-1))


Hydrogen and Ardour synced by jack transport, while frames are set to 128 and buffer is set to 2, the recordings have no jitter and a negative delay about 5ms.

Using this setup

Suse 11.0

spinymouse@suse11:~> uname -r
2.6.25.11-0.1-rt
spinymouse@suse11:~> jackd -V
jackd version 0.109.2 tmpdir /dev/shm protocol 22
spinymouse@suse11:~> qjackctl -v
Qt: 4.4.0
QjackCtl: 0.3.3
spinymouse@suse11:~> hydrogen -v
0.9.4-svn84
spinymouse@suse11:~> ardour2 -v
Ardour/GTK 2.5
(built using 3525 and GCC version 4.3.1 20080507 (prerelease)
[gcc-4_3-branch revision 135036])


Hydrogen and Ardour synced by jack transport, while frames are set to 128 and buffer is set to 2, the recordings have no jitter and a delay about 0.25ms. I guess a quarter milli-second delay will be fine, I didn't made acoustic tests, just looked by Audacity, but this, especially without jitter, should be good enough. I guess it must be one click, without an early reflection like effect, and the phasing when playing the audio track and hydrogen unison should be always the same. Definitive the first beat won't be cut.

So it seems to be that Hydrogen 0.3.2 simply has to be changed by 0.9.4-svn84 to solve this problem.

With frames set to 128 and buffer set to 2 also MIDI jitter seems to be a less serious problem, but depending to the kind of groove MIDI jitter can become a problem and if the frames and buffer have to be raised it will be a serious problem, because there's no headroom for the jitter. I guess if the Jack transport sync will raise, this won't become a problem, there seems to be headroom.

Cheers,
Ralf


_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users


All times are GMT. The time now is 10:12 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.