FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 08-28-2008, 10:58 AM
Ralf Mardorf
 
Default Rosegarden - libart-2.0-2 2.3.17-1 seems to vs 2.3.19-3~bpo.1

My 64 Studio is a 2.1 default install with some extra applications, but
without any security upgrade or any Non-Etch package, excepted of
jack_snapshot I compiled myself.

First I removed rosegarden and rosegarden-data by Synaptic. I held
dependencies, e.g. lilypond.

spinymouse@64studio:~$ cd Desktop
spinymouse@64studio:~/Desktop$ wget
http://downloads.sourceforge.net/rosegarden/rosegarden-1.7.1.tar.bz2?modtime=1217681237&big_mirror=0
spinymouse@64studio:~/Desktop$ tar xjvf rosegarden-1.7.1.tar.bz2
spinymouse@64studio:~/Desktop$ rm rosegarden-1.7.1.tar.bz2
spinymouse@64studio:~/Desktop$ su
64studio:/home/spinymouse/Desktop# cp -pr rosegarden-1.7.1 /usr/src
Ctrl+D (for 64studio:/home/spinymouse/Desktop# exit)
spinymouse@64studio:~/Desktop$ rm -r rosegarden-1.7.1
spinymouse@64studio:~/Desktop$ cd /usr/src/rosegarden-1.7.1

Than I installed, resp. tried to install this packages by Synaptic, with
64 Studio stable, Etch and Etch/Update repositories enabled:
Installing cmake was fine.
I stopped when I tried to solve dependencies for the KDE headers. There
is the need to install libart-2.0-dev.

"libart-2.0-dev:
Depends: libart-2.0-2 (=2.3.17-1) but 2.3.19-3~bpo.1 is to be installed"

I kept the source for Rosegarden 1.7.1 in /usr/src and installed
Rosegarden 1.7.0 again. I expect the same problem, when solving
dependencies for compiling Rosegarden 1.6.1.

After enabling the 64 Studio backports repository I checked out, if this
will solve the dependency. I wonder that it will solve this, seemingly
without removing libart-2.0-2 2.3.19-3~bpo.1.

I decided to complete remove rosegarden and rosegarden-data again and to
install the following packages. Oops, than the message that libart-2.0-2
2.3.17-1 is missing will occur again.

Before I'll go on with compiling 1.7.1, while Rosegarden 1.7.0 is held
and not removed, I'll ask you.

This is the question, without a question mark; it seems to be that
Rosegarden 1.7.0 fakes or comes with a hidden libart-2.0-2 2.3.17-1,
while 2.3.19-3~bpo.1 seems to be installed.

I didn't remove Rosegarden again and didn't install libart-2.0-2-dev.

What shall I do? First testing if the new default Installation using
Rosegarden 1.7.0 will be fine for me, or going on with compiling Rosegarden?

By doing a trick the graphic for the song looks fine and I can play it
with 1.7.0, maybe it will be possible to record and edit, with no or
less crashes than with 64 Studio upgraded to Lenny or Suse 11.0.

_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 06:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org