FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 07-11-2008, 06:37 PM
"Peter Geirnaert"
 
Default Anjuta - libtool , glib missing

Hi ,

I'm trying to build my own program with Anjuta
and it works well to write, compile, and install terminal programs but i'd like to start building a GUI .

With Anjuta's wizard, this are the

results from starting a new libgnome2.0 project
(or any type of project other* than the generic/terminal type):

./autogen.sh

**Error**: You must have 'libtool' installed.

You can get it from ftp://ftp.gnu.org/pub/gnu/

**Error**: You must have 'glib' installed.
You can get it from ftp://ftp.gtk.org/pub/gtk/

Completed ... unsuccessful

I looked for recommended packages for Anjuta in Synaptic and found these:

working:
autoconf 2.61-4
(+ to be installed: m4)
automake1.4
autogen
(+ libopts25 and libopts25-dev)

indent
exuberant-ctags
devhelp
(+ devhelp-common and libdevhelp-1-0)

Not working:
libtool
(+ autotools-dev: depends: libc6-dev but not going to be installed or libc-dev)

gnome-devel
(+ automake1.9, doc-gnome-hig, docbook, docbook-dssl, docbook-to-man, docbook-xsl, gtranslator, intltool, jade,libavahi-client-dev, libavahi-common-dev, libcroco3-dev, libdbus-1-dev, libice-dev, libsm-dev, libsp1c2, libstartup-notification0-dev, libtasn1-3-dev, libx11-dev, libxau-dev, libxcursor-dev, libxdmcp-dev, libxext-dev, libxfixes-dev, libxi-dev, libxinerama-dev, libxrender-dev, libxtst-dev, pkg-config, sp, x11proto-core-dev, x11proto-fixes-dev, x11proto-input-dev, x11proto-kb-dev, x11proto-randr-dev, x11proto-record-dev, x11proto-xinerama-dev, xtrans-dev)

gnome-devel:
*Depends: gnome-core-devel but it is not going to be installed
*Depends: glade-gnome but it is not going to be installed

other try outs to find glib >>

libglibmm-2.4-dev

(+ cpp-2.95, cpp-3.4, gcc-2.95, gcc-3.4, libstdc++2.10-glibc2.2, pkg-config)
libglibmm-2.4-dev:
* Depends: libglibmm-2.4-1c2a (=2.12.0-1) but 2.12.9-0.1~bpo.1 is to be installed
*Depends: libglib2.0-dev but it is not going to be installed

*Depends: libsigc++-2.0-dev but it is not going to be installed

libglibmm-2.4-1c2a-dbg:
* Depends: libglibmm-2.4-1c2a (=2.12.0-1) but 2.12.9-0.1~bpo.1 is to be installed

libglib2.0-dev

(+ pkg-config)
libglib2.0-dev:
* Depends: libglib2.0-0 (=2.14.2-1~etch1) but 2.16.3-2 is to be installed
**force version to 2.14.2-1~etch1 makes 64studio to be removed

I'm a bit stuck here, how can I fix this ?

Any help much appreciated ..

Peter

_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 07-17-2008, 02:22 PM
Daniel James
 
Default Anjuta - libtool , glib missing

Hi Peter,

I was able to install libtool from Etch on a plain 64 Studio 2.1 install
and run a quick test of Anjuta's wizard.

> libglib2.0-dev
> (+ pkg-config)
> libglib2.0-dev:
> Depends: libglib2.0-0 (=2.14.2-1~etch1) but 2.16.3-2 is to be installed
> **force version to 2.14.2-1~etch1 makes 64studio to be removed
>
> I'm a bit stuck here, how can I fix this ?

It looks like the system is trying to install the version of the
libglib2.0-0 package which is from Lenny:

http://packages.debian.org/lenny/libglib2.0-0

Did you previously try to update against Lenny? If so, there are likely
to be some broken packages, and you might prefer to downgrade.

Cheers!

Daniel

_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 07-17-2008, 05:06 PM
"Peter Geirnaert"
 
Default Anjuta - libtool , glib missing

Hi Daniel,



Did you previously try to update against Lenny?*Yes indeed, it's because I added the Lenny repository so I could install a newer version of LMMS that I'm stuck with this experimental candy in my teeth


In case it's of any help ..

here are some files that are installed and are unable to be uninstalled (or 64studio must be removed)



libcairo2 (=1.4.10-1~etch1)***** but**** 1.6.4-1+b1 is to be installed

libfreetype6 (=2.2.1-5+etch2) *** but*** 2.3.5-1+b1 is to be installed

libgcrypt11 *** (=1.2.3-2) *** *** but * ** 1.4.1-1 is to be installed

libglade2-0 *** (=1:2.6.0-4) *** *** but*** 1:2.6.2-1~bpo.1 is to be installed

zlib1g *** *** (=1:1.2.3-13) *** *** but*** 1:1.2.3.3.dfsg-12 is to be installed

libgnome-keyring0 (=0.6.0-3) *** *** but** 2.22.1-1 *** *** is to be installed

libgail-common (=1.8.11-4) *** *** but ** 1.20.0-1~bpo.1 ** is to be installed

libgnome2-0 (=2.16.0-2) *** **** but*** 2.20.0-1~bpo.1 ** is to be installed

libgnomevfs2-0 (=1:2.14.2-7) ***** but*** 1:2.20.0-1~bpo.1**** is to be installed

libglade2-0 (=1:2.6.0-4) *** **** but*** 1:2.6.2-1~bpo.1 * ** is to be installed

libgnomeui-0 (=2.14.1-2) *** *** *** but ** 2.18.1-2~bpo.1***** is to be installed

librsvg2-2 (=2.14.4-3) *** *** *** but * ** 2.16.1-2~bpo.1***** is to be installed

liborbit2 *** (=1:2.14.3-0.2) *** *** but**** 1:2.14.12-0.1**** is to be installed

libpango1.0-0 (=1.18.2-2~etch1) *** but**** 1.20.2-2 * * is to be installed

libfreetype6 (=2.2.1-5+etch2) ***** but ** 2.3.5-1+b1 * * * is to be installed

libgcrypt11 (=1.2.3-2) *** *** *** but 1.4.1-1 * * ** is to be installed

libwxbase2.6-0 (64studio) 2.6.3.2.1.5 *** but***** version (now) 2.6.3.2.2-2
* If so, there are likely to be some broken packages, and you might prefer to downgrade.

I guess I have to reinstall 64studio , or remove 64studio, downgrade the undowngradeable , install 64studio again.

Atm, I'm using* KDevelop* , that looks to be still intact, but I'm not experienced with compilers so it's hard to tell for me.


Thanks anyway for the reply.

Greetings
Peter


_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 07-18-2008, 09:46 AM
"Peter Geirnaert"
 
Default Anjuta - libtool , glib missing

libcvaux-dev, libcv-dev, libhighgui-dev are also unable to be installed here.

I need these packages for the Peripheral to MIDI program, that I'm trying to adjust for Linux, and which is using

code from the OpenCV Library:

The "Open Computer Vision Library" is a collection of algorithms and sample
code for various computer vision problems. The library is compatible with
IPL (Intel's Image Processing Library) and, if available, can use IPP

(Intel's Integrated Performance Primitives) for better performance.

OpenCV provides low level portable data types and operators, and a set
of high level functionalities for video acquisition, image processing and

analysis, structural analysis, motion analysis and object tracking, object
recognition, camera calibration and 3D reconstruction.

http://sourceforge.net/project/showfiles.php?group_id=22870&package_id=16948


64studio is still working fine, with the packages currently installed from Lenny,
but to finish this project I need the OpenCV development files. (libcvaux-dev, libcv-dev, libhighgui-dev)

And I need to repair 64studio into a clean 2.1 version before I can install them.


Some questions I still have are ...

Is it a good idea to remove 64 studio with Synaptic ?
Do I need to make some back-ups of special configuration files, is there a tool for this ?

My plan is to complete a list of installed packages that belong to Lenny, and remove them,

including 64studio and other 'have to be removed - packages'.
Is there a command I could use to make apt (or something) spit out this list for me ?

Thanks in advance for any pointers ;-)

Peter



On Thu, Jul 17, 2008 at 7:06 PM, Peter Geirnaert <peter.geirnaert@gmail.com> wrote:

Hi Daniel,




Did you previously try to update against Lenny?*Yes indeed, it's because I added the Lenny repository so I could install a newer version of LMMS that I'm stuck with this experimental candy in my teeth



In case it's of any help ..

here are some files that are installed and are unable to be uninstalled (or 64studio must be removed)



libcairo2 (=1.4.10-1~etch1)***** but**** 1.6.4-1+b1 is to be installed

libfreetype6 (=2.2.1-5+etch2) *** but*** 2.3.5-1+b1 is to be installed

libgcrypt11 *** (=1.2.3-2) *** *** but * ** 1.4.1-1 is to be installed

libglade2-0 *** (=1:2.6.0-4) *** *** but*** 1:2.6.2-1~bpo.1 is to be installed

zlib1g *** *** (=1:1.2.3-13) *** *** but*** 1:1.2.3.3.dfsg-12 is to be installed

libgnome-keyring0 (=0.6.0-3) *** *** but** 2.22.1-1 *** *** is to be installed

libgail-common (=1.8.11-4) *** *** but ** 1.20.0-1~bpo.1 ** is to be installed

libgnome2-0 (=2.16.0-2) *** **** but*** 2.20.0-1~bpo.1 ** is to be installed

libgnomevfs2-0 (=1:2.14.2-7) ***** but*** 1:2.20.0-1~bpo.1**** is to be installed

libglade2-0 (=1:2.6.0-4) *** **** but*** 1:2.6.2-1~bpo.1 * ** is to be installed

libgnomeui-0 (=2.14.1-2) *** *** *** but ** 2.18.1-2~bpo.1***** is to be installed

librsvg2-2 (=2.14.4-3) *** *** *** but * ** 2.16.1-2~bpo.1***** is to be installed

liborbit2 *** (=1:2.14.3-0.2) *** *** but**** 1:2.14.12-0.1**** is to be installed

libpango1.0-0 (=1.18.2-2~etch1) *** but**** 1.20.2-2 * * is to be installed

libfreetype6 (=2.2.1-5+etch2) ***** but ** 2.3.5-1+b1 * * * is to be installed

libgcrypt11 (=1.2.3-2) *** *** *** but 1.4.1-1 * * ** is to be installed

libwxbase2.6-0 (64studio) 2.6.3.2.1.5 *** but***** version (now) 2.6.3.2.2-2
*
If so, there are likely to be some broken packages, and you might prefer to downgrade.

I guess I have to reinstall 64studio , or remove 64studio, downgrade the undowngradeable , install 64studio again.

Atm, I'm using* KDevelop* , that looks to be still intact, but I'm not experienced with compilers so it's hard to tell for me.



Thanks anyway for the reply.

Greetings
Peter




_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 10:01 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org