FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 06-17-2008, 07:53 AM
Ralf Mardorf
 
Default 64 Studio Lenny and proprietary driver for an integrated ATI

Hi

The integrated ATI is a Radeon X1250-based graphics and the mobo is an
ASUS M2A-VM HDMI.

The actual state of affairs:

* (EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
(EE) Failed to load module "GLcore" (loader failed, 7)
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) AIGLX: Screen 0 is not DRI capable
* If the USB-MIDInterface is fine, the TerraTec sound card isn't fine.
If the TerraTec soundcard is fine, the USB-MIDI isn't fine.
This might has to do with the ATI driver.
* DVD-RAM won't work. This definitively is independent of the ATI
troubles.

What I've done:

1. I enabled the repository for Lenny and disabled all other
repositories.
I reloaded package information and after this Synaptic does this:

Commit Log for Tue Jun 17 08:43:44 2008


Completely removed the following packages:
libgl1-mesa-dri
libgl1-mesa-glx

Removed the following packages:
linux-image-2.6-amd64
linux-image-2.6.18-6-amd64
linux-image-2.6.24-1-amd64

Upgraded the following packages:
xorg (1:7.1.0-19) to 1:7.3+10

Installed the following packages:
libgl1-mesa-swx11 (7.0.3-1)
libgl1-mesa-swx11-dbg (7.0.3-1)
libgl1-mesa-swx11-dev (7.0.3-1)
libosmesa6 (7.0.3-1)
mesa-swx11-source (7.0.3-1)

I disabled the repository for Lenny and enabled some other
repositories and after that Synaptic does an upgrade of Ardour.
2. I downloaded the Linux 86_64 Integrated/Motherboard Radeon Xpress
1250 installer from http://ati.amd.com/support/driver.html.
It's fromMay 21, 2008 and includes the automated installer and
display drivers for X.Org 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, 7.3.
The installed package xorg is version 1:7.3-10 and Synaptic can't
find any broken packages.
3. While doing the download, I've taken a look at the ATI proprietary
Linux driver FAQs, but there I also can't find any help.
4. The only kernel now is 2.6.21-1-multimedia-amd64, headers are also
installed.
5. 64studio:/home/spinymouse/Desktop/tmp# sh
ati-driver-installer-8-5-x86.x86_64.run
6. It seems to be "All good".
7. I choose "Install Driver"
8. I choose "Automatic" mode of installation.
9. Instead of killing X I've done a reboot (xorg.conf is still an
optimized one for the ATI driver, I won't attach it now, because
this might stop this mail from coming direct through the list and
only will cause the administrators work).
10. spinymouse@64studio:~$ grep "EE" /var/log/Xorg.0.log
Current Operating System: Linux 64studio 2.6.21-1-multimedia-amd64
#1 SMP PREEMPT RT Fri Jun 22 00:00:33 UTC 2007 x86_64
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
(EE) Failed to load module "GLcore" (loader failed, 7)
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(EE) AIGLX: Screen 0 is not DRI capable

Nothing changed for the ATI driver. I'll copy the xorg.conf into another
mail right now.

Any ideas, what I'm doing wrong?

Cheers,
Ralf

_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 02:54 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org