FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio User

 
 
LinkBack Thread Tools
 
Old 06-10-2008, 10:07 PM
Ralf Mardorf
 
Default pstree won't work the way I hope it would - hw:0 already in use after boot, with no programs running

> some command to see what process is using hw:0
> to find out where the problem is.
pstree

shows which process is using another process in form of a tree scheme.
If there will be an application using OSS or ALSA etc. this is shown.
I know this myself just for some hours, before I only knew about ps aux,
but it isn't a help, because we can't know all applications, that might
have to do with OSS and ALSA or any other sound server.
Force the appearance of the problem by removing "killall esd &" and run
pstree, resp. oops, I'm wrong, I can't see ALSA with pstree. Does
someone know a way to see which application will use another application
by showing it complete?

spinymouse@64studio:~$ pstree
init─┬─NetworkManager
├─NetworkManagerD
├─acpid
├─atd
├─atieventsd
├─avahi-daemon───avahi-daemon
├─cron
├─das_watchdog───{das_watchdog}
├─2*[dbus-daemon]
├─dbus-launch
├─dcopserver
├─desched/0
├─desched/1
├─dhcdbd
├─dirmngr
├─events/0
├─events/1
├─exim4
├─gconfd-2
├─gdm───gdm─┬─Xorg
│ └─startkde─┬─kwrapper
│ └─seahorse-agent
├─6*[getty]
├─gnome-keyring-d
├─hald───hald-runner─┬─hald-addon-acpi
│ ├─hald-addon-inpu
│ └─hald-addon-stor
├─hcid
├─icecast───3*[{icecast}]
├─kaccess
├─kded
├─kdeinit─┬─ardour-2.4.1───7*[{ardour-2.4.1}]
│ ├─icedove───run-mozilla.sh───icedove-bin───13*[{icedove-bin}]
│ ├─2*[kio_file]
│ ├─kio_media
│ ├─klauncher
│ ├─kwin
│ └─qjackctl─┬─jackd───3*[{jackd}]
│ └─2*[{qjackctl}]
├─kdesktop
├─kgpg
├─khelper
├─kicker
├─klogd
├─knotify
├─krfcommd
├─ksmserver
├─kthread─┬─IRQ-1
│ ├─IRQ-12
│ ├─IRQ-14
│ ├─IRQ-16
│ ├─IRQ-17
│ ├─IRQ-18
│ ├─IRQ-19
│ ├─IRQ-20
│ ├─IRQ-21
│ ├─IRQ-22
│ ├─IRQ-4
│ ├─IRQ-7
│ ├─IRQ-8
│ ├─IRQ-9
│ ├─aio/0
│ ├─aio/1
│ ├─ata/0
│ ├─ata/1
│ ├─ata_aux
│ ├─flush_filesd/0
│ ├─flush_filesd/1
│ ├─kacpid
│ ├─kblockd/0
│ ├─kblockd/1
│ ├─khpsbpkt
│ ├─khubd
│ ├─6*[kjournald]
│ ├─kmirrord
│ ├─knodemgrd_0
│ ├─kpsmoused
│ ├─kseriod
│ ├─ksnapd
│ ├─ksuspend_usbd
│ ├─kswapd0
│ ├─2*[pdflush]
│ ├─scsi_eh_0
│ ├─scsi_eh_1
│ ├─scsi_eh_2
│ ├─scsi_eh_3
│ ├─scsi_eh_4
│ ├─scsi_eh_5
│ └─scsi_eh_6
├─migration/0
├─migration/1
├─nmbd
├─pcscd───{pcscd}
├─2*[posix_cpu_timer]
├─pppd
├─sensord
├─smbd───2*[smbd]
├─softirq-block/0
├─softirq-block/1
├─softirq-high/0
├─softirq-high/1
├─2*[softirq-net-rx/]
├─2*[softirq-net-tx/]
├─softirq-rcu/0
├─softirq-rcu/1
├─softirq-sched/0
├─softirq-sched/1
├─2*[softirq-tasklet]
├─softirq-timer/0
├─softirq-timer/1
├─sshd
├─start_kdeinit
├─syslogd
├─system-tools-ba───dbus-daemon
├─udevd
└─yakuake───bash───pstree
spinymouse@64studio:~$ su
Password:
64studio:/home/spinymouse# pstree
init─┬─NetworkManager
├─NetworkManagerD
├─acpid
├─atd
├─atieventsd
├─avahi-daemon───avahi-daemon
├─cron
├─das_watchdog───{das_watchdog}
├─2*[dbus-daemon]
├─dbus-launch
├─dcopserver
├─desched/0
├─desched/1
├─dhcdbd
├─dirmngr
├─events/0
├─events/1
├─exim4
├─gconfd-2
├─gdm───gdm─┬─Xorg
│ └─startkde─┬─kwrapper
│ └─seahorse-agent
├─6*[getty]
├─gnome-keyring-d
├─hald───hald-runner─┬─hald-addon-acpi
│ ├─hald-addon-inpu
│ └─hald-addon-stor
├─hcid
├─icecast───3*[{icecast}]
├─kaccess
├─kded
├─kdeinit─┬─ardour-2.4.1───7*[{ardour-2.4.1}]
│ ├─icedove───run-mozilla.sh───icedove-bin───9*[{icedove-bin}]
│ ├─kio_file
│ ├─klauncher
│ ├─kwin
│ └─qjackctl─┬─jackd───3*[{jackd}]
│ └─2*[{qjackctl}]
├─kdesktop
├─kgpg
├─khelper
├─kicker
├─klogd
├─knotify
├─krfcommd
├─ksmserver
├─kthread─┬─IRQ-1
│ ├─IRQ-12
│ ├─IRQ-14
│ ├─IRQ-16
│ ├─IRQ-17
│ ├─IRQ-18
│ ├─IRQ-19
│ ├─IRQ-20
│ ├─IRQ-21
│ ├─IRQ-22
│ ├─IRQ-4
│ ├─IRQ-7
│ ├─IRQ-8
│ ├─IRQ-9
│ ├─aio/0
│ ├─aio/1
│ ├─ata/0
│ ├─ata/1
│ ├─ata_aux
│ ├─flush_filesd/0
│ ├─flush_filesd/1
│ ├─kacpid
│ ├─kblockd/0
│ ├─kblockd/1
│ ├─khpsbpkt
│ ├─khubd
│ ├─6*[kjournald]
│ ├─kmirrord
│ ├─knodemgrd_0
│ ├─kpsmoused
│ ├─kseriod
│ ├─ksnapd
│ ├─ksuspend_usbd
│ ├─kswapd0
│ ├─2*[pdflush]
│ ├─scsi_eh_0
│ ├─scsi_eh_1
│ ├─scsi_eh_2
│ ├─scsi_eh_3
│ ├─scsi_eh_4
│ ├─scsi_eh_5
│ └─scsi_eh_6
├─migration/0
├─migration/1
├─nmbd
├─pcscd───{pcscd}
├─2*[posix_cpu_timer]
├─pppd
├─sensord
├─smbd───2*[smbd]
├─softirq-block/0
├─softirq-block/1
├─softirq-high/0
├─softirq-high/1
├─2*[softirq-net-rx/]
├─2*[softirq-net-tx/]
├─softirq-rcu/0
├─softirq-rcu/1
├─softirq-sched/0
├─softirq-sched/1
├─2*[softirq-tasklet]
├─softirq-timer/0
├─softirq-timer/1
├─sshd
├─start_kdeinit
├─syslogd
├─system-tools-ba───dbus-daemon
├─udevd
└─yakuake───bash───su───bash ───pstree
64studio:/home/spinymouse#

There might be something wrong, I had to reboot, because my soundcard
wasn't shown in Jack and after reboot it has been fine again. No,
everything seems to be fine, there's nothing wrong with ALSA, the
messages from Jack are fine. pstree won't work the way I hope it would.

Hmm. Sorry, I don't know a command that will help you.
_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 

Thread Tools




All times are GMT. The time now is 06:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org