FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio Developer

 
 
LinkBack Thread Tools
 
Old 05-14-2008, 05:07 PM
Free Ekanayaka
 
Default Upgrading 2.1 to lenny

Hi all,

I think I've fixed most of the issues that prevented a clean upgrade to
lenny from 64 Studio 2.1 (rc1/rc2). Here's the procedure with Synaptic:

1) Remove a few exim related packages, which seem to be broken in lenny:

exim4 exim4-base exim4-config exim4-daemon-light mailx mutt

2) Upgrade to the testing branch of 64 Studio, in particular make
sure that your 64studio* packages get upgraded to version 2.1

3) Add lenny to your APT sources and hit the refresh button

4) Mark everything for upgrade, hit the apply button and follow the
instructions. You will be asked if you want to restart a few
services, always aswer yes. Moreover for three files, namely:

/etc/security/limits.conf
/etc/gdm/gdm.conf
/etc/xdg/menu/gnome-applications.menu

you will be asked wether to keep them or replace them with a
newer version. CHOOSE TO KEEP THEM.

Steps 1) and 2) will not be needed on a fresh 2.1 install (final
version). If you want to test it here is the latest build:

http://cdd.64studio.com/etch/builds/

which is now VERY close to the final 2.1

Happy testing!

Free


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-14-2008, 05:57 PM
Free Ekanayaka
 
Default Upgrading 2.1 to lenny

Hi,

On Wed, 2008-05-14 at 19:07 +0200, Free Ekanayaka wrote:

> 4) Mark everything for upgrade, hit the apply button and follow the
> instructions.
I forgot to mention that a few packages will be removed, most noticeably
ardour and sysv-rc-bootsplash. This is because ardour is not in lenny
yet, but you can grab it from sid. The sysv-rc-bootsplash package
just draws the boot progress bar, not a big deal.

The kernel will also be upgraded with a non-realtime one, but you can
still boot the good old 2.6.21 from the grub menu.

I plan to provide a lenny backport for ardour and a new kernel.

Ciao!

Free



_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-14-2008, 10:41 PM
dave
 
Default Upgrading 2.1 to lenny

Free Ekanayaka wrote:
> Hi all,
>
> I think I've fixed most of the issues that prevented a clean upgrade to
> lenny from 64 Studio 2.1 (rc1/rc2). Here's the procedure with Synaptic:
>
> 1) Remove a few exim related packages, which seem to be broken in lenny:
>
> exim4 exim4-base exim4-config exim4-daemon-light mailx mutt
>
> 2) Upgrade to the testing branch of 64 Studio, in particular make
> sure that your 64studio* packages get upgraded to version 2.1
>
> 3) Add lenny to your APT sources and hit the refresh button
>
> 4) Mark everything for upgrade, hit the apply button and follow the
> instructions. You will be asked if you want to restart a few
> services, always aswer yes. Moreover for three files, namely:
>
> /etc/security/limits.conf
> /etc/gdm/gdm.conf
> /etc/xdg/menu/gnome-applications.menu
>
> you will be asked wether to keep them or replace them with a
> newer version. CHOOSE TO KEEP THEM.
>
> Steps 1) and 2) will not be needed on a fresh 2.1 install (final
> version). If you want to test it here is the latest build:
>
> http://cdd.64studio.com/etch/builds/
>
> which is now VERY close to the final 2.1
>
> Happy testing!
>
> Free
>
>
> _______________________________________________
> 64studio-devel mailing list
> 64studio-devel@64studio.com
> http://lists.64studio.com/mailman/listinfo/64studio-devel
>
>
Hi Free, hope you're well,

$ cat /boot/grub/menu.lst

title 64studio_master_i386_080514,16:22, 2.6.21-1-multimedia-486

Install is beautiful and smooth.
Going to stay with the default install for a while,
then upgrade to lenny following your instructions.

Thanks for all your great work and time.

dave.


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-15-2008, 06:36 AM
Free Ekanayaka
 
Default Upgrading 2.1 to lenny

Hi Dave,

On Wed, 2008-05-14 at 23:41 +0100, dave wrote:
> >
> >
> Hi Free, hope you're well,
>
> $ cat /boot/grub/menu.lst
>
> title 64studio_master_i386_080514,16:22, 2.6.21-1-multimedia-486
>
> Install is beautiful and smooth.



> Going to stay with the default install for a while,
> then upgrade to lenny following your instructions.
>
> Thanks for all your great work and time.
>
Thank you for your report, and don't forget to let us know
how it goes once you decide to upgrade!

Ciao,

Free


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-16-2008, 10:46 AM
dave
 
Default Upgrading 2.1 to lenny

Hi Free, hope you're well,

Free wrote: Wed May 14 23:41:01 BST 2008
> 1 Remove a few exim related packages, which seem to be broken in lenny:
> exim4 exim4-base exim4-config exim4-daemon-light mailx mutt
> 2 Upgrade to the testing branch of 64 Studio, in particular make
> sure that your 64studio* packages get upgraded to version 2.1
> Steps 1) and 2) will not be needed on a fresh 2.1 install (final
> version). If you want to test it here is the latest build:

Fri May 16: Upgrade using Synaptic.
I did not do Step 1: Remove a few exim related packages.

Synaptic Messages.
Upgrade "completes" with messages:

/var/lib/scrollkeeper/sv/scrollkeeper_extended_cl.xml:2031: parser error
: Extra content at the end of the document
E: /var/cache/apt/archives/libwine_0.9.59-1_i386.deb: trying to
overwrite `/usr/lib/wine/acledit.dll.so', which is also in package wine

Errors were encountered while processing:
libwine-gphoto2
wine-bin
libwine-print
libwine-ldap
libwine-cms
libwine-alsa
wine
libwine-gl
libwine-sane
wine-utils

Still in synaptic Broken libwine "Re-Apply upgrade"... ok!

(Reading database ... 119376 files and directories currently installed.)
Unpacking libwine (from .../libwine_0.9.59-1_i386.deb) ...
Setting up libwine (0.9.59-1) ...
Setting up libwine-alsa (0.9.59-1) ...
Setting up libwine-cms (0.9.59-1) ...
Setting up libwine-gl (0.9.59-1) ...
Setting up libwine-gphoto2 (0.9.59-1) ...
Setting up libwine-ldap (0.9.59-1) ...
Setting up libwine-print (0.9.59-1) ...
Setting up libwine-sane (0.9.59-1) ...
Setting up wine-bin (0.9.59-1) ...
Setting up wine-utils (0.9.59-1) ...
Setting up wine (0.9.59-1) ...

halt
1st restart: 64studio_master_i386_080514,16:22, 2.6.21-1-multimedia-486

2.6.21-1-multimedia-486 #1 SMP PREEMPT RT Fri Jun 22 19:13:23 UTC 2007
i686 GNU/Linux
Check upgrades:
kept back:
gok libgtk1.2 openssh-client openssh-server
upgrade:
icecast-server libwine libwine-alsa libwine-cms libwine-gl
libwine-gphoto2 libwine-ldap libwine-print libwine-sane man-db ssh wine
wine-bin wine-utils

All upgrades complete ok!
I am getting exim related package errors.

System seems fine, wine upgraded and configured ok!
No scrollkeeper messages now.
Going to try again, using step 1 this time.

Cheers,

dave.


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-16-2008, 02:34 PM
dave
 
Default Upgrading 2.1 to lenny

Hi Free,

Free wrote:
> 1) Remove a few exim related packages, which seem to be broken in lenny:
> exim4 exim4-base exim4-config exim4-daemon-light mailx mutt

Wed May 14
Install 1 test 1.
Install 64studio_master_i386_080514,16:22, 2.6.21-1-multimedia-486
Clean install.

not doing Step 1 Results in:
Setting up exim4-daemon-light (4.69-2+b1) ...
Starting MTA:exim: incompatible command-line options or arguments
invoke-rc.d: initscript exim4, action "start" failed.
dpkg: error processing exim4-daemon-light (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of exim4:
exim4 depends on exim4-daemon-light | exim4-daemon-heavy |
exim4-daemon-custom; however:
Package exim4-daemon-light is not configured yet.
Package exim4-daemon-heavy is not installed.
Package exim4-daemon-custom is not installed.
dpkg: error processing exim4 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bsd-mailx:
bsd-mailx depends on exim4 | mail-transport-agent; however:
Package exim4 is not configured yet.
Package mail-transport-agent is not installed.
Package exim4-daemon-light which provides mail-transport-agent is not
configured yet.
dpkg: error processing bsd-mailx (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mailx:
mailx depends on bsd-mailx; however:
Package bsd-mailx is not configured yet.
dpkg: error processing mailx (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
exim4-daemon-light
exim4
bsd-mailx
mailx
E: Sub-process /usr/bin/dpkg returned an error code (1)

ref: Fri May 16 11:46:09 BST 2008
/var/lib/scrollkeeper/sv/scrollkeeper_extended_cl.xml:2031: parser error
: Extra content at the end of the document
E: /var/cache/apt/archives/libwine_0.9.59-1_i386.deb: trying to
overwrite `/usr/lib/wine/acledit.dll.so', which is also in package wine

- - - - - - - - - - - - - - - - - - - - - - - - - - - -
Fri May 16
Install 2 test 2
Install 64studio_master_i386_080514,16:22, 2.6.21-1-multimedia-486
Clean install...Same as install 1.

doing Step 1.
> 1) Remove a few exim related packages, which seem to be broken in lenny:
> exim4 exim4-base exim4-config exim4-daemon-light mailx mutt

# apt-get remove --purge exim4 exim4-base exim4-config
exim4-daemon-light mailx mutt

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package exim4 is not installed, so not removed
Package exim4-base is not installed, so not removed
Package exim4-config is not installed, so not removed
Package exim4-daemon-light is not installed, so not removed
Package mailx is not installed, so not removed
Package mutt is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 911 not upgraded.
#
These packages are not installed by default
so I expect the same outcome as test 1?

Cheers,

dave.


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-16-2008, 03:07 PM
"R.Wolff"
 
Default Upgrading 2.1 to lenny

Hi Dave,
I'm not free, but on my install (fresh 2.1 rc2) those packages were installed.
I already uninstalled them since I have no need for a mail-server or some such
things via synaptic. Worked atreat.

Cheers
Raphael


dave schrieb:
> Hi Free,
>
>......
> These packages are not installed by default
> so I expect the same outcome as test 1?
>
> Cheers,
>
> dave.
>
>
> _______________________________________________
> 64studio-devel mailing list
> 64studio-devel@64studio.com
> http://lists.64studio.com/mailman/listinfo/64studio-devel
>

--
________________________________
"A mind is like a parachute -
It doesnt work if it's not open."

|- - - - - - - Frank Zappa - - - - - - -|

_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-16-2008, 04:12 PM
dave
 
Default Upgrading 2.1 to lenny

Hi Raphael, hope you're well,

I have downloaded

http://cdd.64studio.com/etch/builds/

The install is great :-) Thinking that if I didn't remove the packages broken in lenny.
I would get errors, I installed without removing anything, so I expected errors.
No problem. I "wanted to see" the errors, and send a report.
I installed again, this time to go for the clean upgrade.
To my suprise when I went to remove the broken packages, they are not installed?
So I have a fresh install waiting for the next step.

Cheers,

dave.

R.Wolff wrote:
> Hi Dave,
> I'm not free, but on my install (fresh 2.1 rc2) those packages were installed.
> I already uninstalled them since I have no need for a mail-server or some such
> things via synaptic. Worked atreat.
>
> Cheers
> Raphael
>
>
> dave schrieb:
>
>> Hi Free,
>>
>> ......
>> These packages are not installed by default
>> so I expect the same outcome as test 1?
>>
>> Cheers,
>>
>> dave.
>>
>>
>> _______________________________________________
>> 64studio-devel mailing list
>> 64studio-devel@64studio.com
>> http://lists.64studio.com/mailman/listinfo/64studio-devel
>>
>>
>
>


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-18-2008, 07:45 AM
dave
 
Default Upgrading 2.1 to lenny

Hi Free,

64studio_master_i386.iso 15-May-2008 10:24 799M

/Sat May 17 : //Sun May 1//8 /
Two installs of this image,
1: 64studio on dedicated disk.
2: Multi boot environment.
Both installs clean, beautiful :-)
The upgrade to lenny (Synaptic) was fine.
I had to re-apply wine upgrade, but no problems with exim.

Cheers,

Dave.



_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 05-27-2008, 07:08 PM
Toni Haapanen
 
Default Upgrading 2.1 to Lenny

Hi,

I followed Free's instructions and i managed to upgrade 2.1 to Lenny.
Thanks! I have AMD-64.

I think (!) i told during installation not to replace
/etc/security/limits.conf, but after the upgrade previous settings were
lost. I had to add my old settings to limits.conf (and then log out -
log in) in order to be able to open jack. Before this jack only worked
when running it as root.

I was not able to install 64-studio-themes. Error message:
E: /var/cache/apt/archives/64studio-themes_2.1_all.deb: trying to
overwrite `/usr/share/applications/qsynth.desktop', which is also in
package qsynth

Else, everything went fine. Ardour (2.4.1) did not disappear, but if i
remember correctly, i had built it from source.

Good work.

Greetings,
Toni


Free Ekanayaka wrote:
>/ Hi all,
/>/
/>/ I think I've fixed most of the issues that prevented a clean upgrade to
/>/ lenny from 64 Studio 2.1 (rc1/rc2). Here's the procedure with Synaptic:
/>/
/>/ 1) Remove a few exim related packages, which seem to be broken in lenny:
/>/
/>/ exim4 exim4-base exim4-config exim4-daemon-light mailx mutt
/>/
/>/ 2) Upgrade to the testing branch of 64 Studio, in particular make
/>/ sure that your 64studio* packages get upgraded to version 2.1
/>/
/>/ 3) Add lenny to your APT sources and hit the refresh button
/>/
/>/ 4) Mark everything for upgrade, hit the apply button and follow the
/>/ instructions. You will be asked if you want to restart a few
/>/ services, always aswer yes. Moreover for three files, namely:
/>/
/>/ /etc/security/limits.conf
/>/ /etc/gdm/gdm.conf
/>/ /etc/xdg/menu/gnome-applications.menu
/>/
/>/ you will be asked wether to keep them or replace them with a
/>/ newer version. CHOOSE TO KEEP THEM.
/>/
/>/ Steps 1) and 2) will not be needed on a fresh 2.1 install (final
/>/ version). If you want to test it here is the latest build:
/>/
/>/ http://cdd.64studio.com/etch/builds/
/>/
/>/ which is now VERY close to the final 2.1
/>/
/>/ Happy testing!
/>/
/>/ Free
/>/
/>


_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 

Thread Tools




All times are GMT. The time now is 07:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org