FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > 64 Studio > 64 Studio Developer

 
 
LinkBack Thread Tools
 
Old 01-08-2009, 09:16 AM
Daniel James
 
Default 64studio 3.0 software wishlist

Hi Nate,

since 64studio seems to
be using ubuntu I remember a nice little softsynth I worked with in
ubuntu at one time called mx44. Small, stable, 4 oscillators I believe.
here's the page for the project:


http://web.comhem.se/luna/


Never tried it, but it looks interesting. Is it stable?

Cheers!

Daniel
_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 01-09-2009, 02:20 PM
"Nate figlar"
 
Default 64studio 3.0 software wishlist

Well daniel it's been a while since I had it on a system but I can't
think of a time when it wasn't stable. I believe I even installed it
one of the early 2.0 releases from an ubuntu deb package and ran fine
all dependencies where met as well. unfortunately right now I am
trying to finish up a big project and not in a good position to test
to verify but hopefully someone testing would be up to give it a try.

On Thu, Jan 8, 2009 at 5:16 AM, Daniel James <daniel@64studio.com> wrote:
> Hi Nate,
>
>> since 64studio seems to be using ubuntu I remember a nice little softsynth
>> I worked with in ubuntu at one time called mx44. Small, stable, 4
>> oscillators I believe. here's the page for the project:
>>
>> http://web.comhem.se/luna/
>
> Never tried it, but it looks interesting. Is it stable?
>
> Cheers!
>
> Daniel
>



--
Nathan Figlar
sonorone@gmail.com
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-09-2009, 02:20 PM
"Nate figlar"
 
Default 64studio 3.0 software wishlist

Well daniel it's been a while since I had it on a system but I can't
think of a time when it wasn't stable. I believe I even installed it
one of the early 2.0 releases from an ubuntu deb package and ran fine
all dependencies where met as well. unfortunately right now I am
trying to finish up a big project and not in a good position to test
to verify but hopefully someone testing would be up to give it a try.

On Thu, Jan 8, 2009 at 5:16 AM, Daniel James <daniel@64studio.com> wrote:
> Hi Nate,
>
>> since 64studio seems to be using ubuntu I remember a nice little softsynth
>> I worked with in ubuntu at one time called mx44. Small, stable, 4
>> oscillators I believe. here's the page for the project:
>>
>> http://web.comhem.se/luna/
>
> Never tried it, but it looks interesting. Is it stable?
>
> Cheers!
>
> Daniel
>



--
Nathan Figlar
sonorone@gmail.com
_______________________________________________
64studio-users mailing list
64studio-users@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-users
 
Old 01-09-2009, 03:10 PM
Jarom√≠r MikeŇ°
 
Default 64studio 3.0 software wishlist

< Well daniel it's been a while since I had it on a system but I can't
< think of a time when it wasn't stable. I believe I even installed it
< one of the early 2.0 releases from an ubuntu deb package and ran fine
< all dependencies where met as well. unfortunately right now I am
< trying to finish up a big project and not in a good position to test
< to verify but hopefully someone testing would be up to give it a try.
<

I would like to test it ... but I am not able to run it with jack.

This written on the websites:
http://web.comhem.se/luna/
The Mx44 software works by itself though, and with a bit of hacking you could probably quite easily add the missing pieces using other free sources. Or why not integrate it with ALSA and JACK. Mmmm ... No wait, that is already done .... But then DSSI maybe?

Any advice how to run with jack?

mira
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-09-2009, 05:37 PM
"Nate figlar"
 
Default 64studio 3.0 software wishlist

Hello mira,

Well I do know that I could only get mx44 to start with Jack. I do
remember seeing that on the site but honestly everything I do
audio-wise is done in jack so i never really even tried it stand alone
without jack. I am actually getting the 3.0 image now and going to try
it out as long as I can get it on my laptop ok. this will be a 32 bit
version.

As for running with jack basically I ran like any other jack app.
start jack, start mx44, make the connections in the connections panel
in jack, and seemed to work fine. hopefully it will still do the same
this time around.

nate

On Fri, Jan 9, 2009 at 11:10 AM, Jarom√*r MikeŇ° <mira.mikes@seznam.cz> wrote:
> < Well daniel it's been a while since I had it on a system but I can't
> < think of a time when it wasn't stable. I believe I even installed it
> < one of the early 2.0 releases from an ubuntu deb package and ran fine
> < all dependencies where met as well. unfortunately right now I am
> < trying to finish up a big project and not in a good position to test
> < to verify but hopefully someone testing would be up to give it a try.
> <
>
> I would like to test it ... but I am not able to run it with jack.
>
> This written on the websites:
> http://web.comhem.se/luna/
> The Mx44 software works by itself though, and with a bit of hacking you could probably quite easily add the missing pieces using other free sources. Or why not integrate it with ALSA and JACK. Mmmm ... No wait, that is already done .... But then DSSI maybe?
>
> Any advice how to run with jack?
>
> mira
> _______________________________________________
> 64studio-devel mailing list
> 64studio-devel@64studio.com
> http://lists.64studio.com/mailman/listinfo/64studio-devel
>



--
Nathan Figlar
sonorone@gmail.com
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-09-2009, 06:10 PM
Jarom√≠r MikeŇ°
 
Default 64studio 3.0 software wishlist

< Well I do know that I could only get mx44 to start with Jack. I do
< remember seeing that on the site but honestly everything I do
< audio-wise is done in jack so i never really even tried it stand alone
< without jack. I am actually getting the 3.0 image now and going to try
< it out as long as I can get it on my laptop ok. this will be a 32 bit
< version.
<
< As for running with jack basically I ran like any other jack app.
< start jack, start mx44, make the connections in the connections panel
< in jack, and seemed to work fine. hopefully it will still do the same
< this time around.
<
< nate
<
< On Fri, Jan 9, 2009 at 11:10 AM, Jarom√*r MikeŇ° <mira.mikes@seznam.cz> wrote:
< > < Well daniel it's been a while since I had it on a system but I can't
< > < think of a time when it wasn't stable. I believe I even installed it
< > < one of the early 2.0 releases from an ubuntu deb package and ran fine
< > < all dependencies where met as well. unfortunately right now I am
< > < trying to finish up a big project and not in a good position to test
< > < to verify but hopefully someone testing would be up to give it a try.
< > <
< >
< > I would like to test it ... but I am not able to run it with jack.
< >
< > This written on the websites:
< > http://web.comhem.se/luna/
< > The Mx44 software works by itself though, and with a bit of hacking you could
< probably quite easily add the missing pieces using other free sources. Or why
< not integrate it with ALSA and JACK. Mmmm ... No wait, that is already done
< .... But then DSSI maybe?
< >
< > Any advice how to run with jack?
< >
< > mira

Hi Nate,

when jack is running then is impossible to get run mx44 by clicking icon from main menu.
I've tried from terminal here is output:

mira@64studio:~$ mx44
jack_client_new: deprecated
engine sample rate: 44100

Jack nframes: 128

client activated

Capture ports:
system:capture_1
system:capture_2
Mx44:Mx44_L
Mx44:Mx44_R

Playback ports:
systemlayback_1
systemlayback_2

sizeof 48 voices: 29952, 16 keyboards: 41352, 128 patches: 61440

Voice data loaded


Can't run in realtime! Please do (as 'root'):
chown root.root /usr/bin/mx44.bin && chmod 4711 /usr/bin/mx44.bin

JackFifo::TimedWait name = /dev/shm/jack_fifo.default_Mx44 usec = 2147483647 revents 0
SuspendRefNum error
JackClient::Execute error name = Mx44
/dev/midi: No such file or directory

Voice data saved

Thankyou for using Mx4!

##

I am curious how it will behave on your system.
Actually my installation of 3.0 Alpha was done by upgrading from 2.1 realese before the iso was available.
Hope there is no difference.

Thanks for your answer

mira

_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-09-2009, 08:02 PM
"Nate figlar"
 
Default 64studio 3.0 software wishlist

Mira,

Ok install went smooth from the latest iso image and got sound up and
running through jack no problems (that you dev team for another great
release). now I added the universe repository only to add the mx44
app. I had the same result. I could not start the app with jack. the
output from terminal is as follows:

nate@64studio:~$ mx44
Port subscribed: sender: 129:0 dest: 130:0
jack_client_new: deprecated
engine sample rate: 48000

Jack nframes: 512

client activated

Capture ports:
system:capture_1
system:capture_2
system:midi_capture_1
system:midi_capture_2
Mx44:Mx44_L
Mx44:Mx44_R

Playback ports:
systemlayback_1
systemlayback_2
system:midi_playback_1
system:midi_playback_2
system:midi_playback_3

sizeof 48 voices: 29952, 16 keyboards: 41352, 128 patches: 61440

Voice data loaded

/dev/midi: No such file or directory
JackFifo::TimedWait name = /dev/shm/jack_fifo.default_Mx44 usec =
2147483647 revents 0
SuspendRefNum error
JackClient::Execute error name = Mx44

Voice data saved

Thankyou for using Mx4!

Now when I run the jack gui control but do NOT start jack I can start
mx44 fine and connect my midi controller to it by using the ALSA tab
in the jack audio connection kit gui. runs fine but I would love to
run it in jack for actual use. until now this hasn't been a problem.

Another issue I suspect might be related is that I see no devices
other than system in the MIDI tab when jack is started and mx44
terminal say there is no /dev/midi directory. This is the same result
using all 3 MIDI drivers in jack setup. so I am assuming jack isn't
reading my MIDI devices properly? hopefully someone can direct us in
the right direction on this as mx44 starts with jack I am wondering if
it might be a jack MIDI issue?

Nate

2009/1/9 Jarom√*r MikeŇ° <mira.mikes@seznam.cz>:
> < Well I do know that I could only get mx44 to start with Jack. I do
> < remember seeing that on the site but honestly everything I do
> < audio-wise is done in jack so i never really even tried it stand alone
> < without jack. I am actually getting the 3.0 image now and going to try
> < it out as long as I can get it on my laptop ok. this will be a 32 bit
> < version.
> <
> < As for running with jack basically I ran like any other jack app.
> < start jack, start mx44, make the connections in the connections panel
> < in jack, and seemed to work fine. hopefully it will still do the same
> < this time around.
> <
> < nate
> <
> < On Fri, Jan 9, 2009 at 11:10 AM, Jarom√*r MikeŇ° <mira.mikes@seznam.cz> wrote:
> < > < Well daniel it's been a while since I had it on a system but I can't
> < > < think of a time when it wasn't stable. I believe I even installed it
> < > < one of the early 2.0 releases from an ubuntu deb package and ran fine
> < > < all dependencies where met as well. unfortunately right now I am
> < > < trying to finish up a big project and not in a good position to test
> < > < to verify but hopefully someone testing would be up to give it a try.
> < > <
> < >
> < > I would like to test it ... but I am not able to run it with jack.
> < >
> < > This written on the websites:
> < > http://web.comhem.se/luna/
> < > The Mx44 software works by itself though, and with a bit of hacking you could
> < probably quite easily add the missing pieces using other free sources. Or why
> < not integrate it with ALSA and JACK. Mmmm ... No wait, that is already done
> < .... But then DSSI maybe?
> < >
> < > Any advice how to run with jack?
> < >
> < > mira
>
> Hi Nate,
>
> when jack is running then is impossible to get run mx44 by clicking icon from main menu.
> I've tried from terminal here is output:
>
> mira@64studio:~$ mx44
> jack_client_new: deprecated
> engine sample rate: 44100
>
> Jack nframes: 128
>
> client activated
>
> Capture ports:
> system:capture_1
> system:capture_2
> Mx44:Mx44_L
> Mx44:Mx44_R
>
> Playback ports:
> systemlayback_1
> systemlayback_2
>
> sizeof 48 voices: 29952, 16 keyboards: 41352, 128 patches: 61440
>
> Voice data loaded
>
>
> Can't run in realtime! Please do (as 'root'):
> chown root.root /usr/bin/mx44.bin && chmod 4711 /usr/bin/mx44.bin
>
> JackFifo::TimedWait name = /dev/shm/jack_fifo.default_Mx44 usec = 2147483647 revents 0
> SuspendRefNum error
> JackClient::Execute error name = Mx44
> /dev/midi: No such file or directory
>
> Voice data saved
>
> Thankyou for using Mx4!
>
> ##
>
> I am curious how it will behave on your system.
> Actually my installation of 3.0 Alpha was done by upgrading from 2.1 realese before the iso was available.
> Hope there is no difference.
>
> Thanks for your answer
>
> mira
>
> _______________________________________________
> 64studio-devel mailing list
> 64studio-devel@64studio.com
> http://lists.64studio.com/mailman/listinfo/64studio-devel
>



--
Nathan Figlar
sonorone@gmail.com
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-09-2009, 08:50 PM
Jarom√≠r MikeŇ°
 
Default 64studio 3.0 software wishlist

Hello Nate,

Maybe the problem is because of new version of jack ... just guessing.
I was sending email with question to author ... email came back undelivered.

cheers

mira

< Mira,
<
< Ok install went smooth from the latest iso image and got sound up and
< running through jack no problems (that you dev team for another great
< release). now I added the universe repository only to add the mx44
< app. I had the same result. I could not start the app with jack. the
< output from terminal is as follows:
<
< nate@64studio:~$ mx44
< Port subscribed: sender: 129:0 dest: 130:0
< jack_client_new: deprecated
< engine sample rate: 48000
<
< Jack nframes: 512
<
< client activated
<
< Capture ports:
< system:capture_1
< system:capture_2
< system:midi_capture_1
< system:midi_capture_2
< Mx44:Mx44_L
< Mx44:Mx44_R
<
< Playback ports:
< systemlayback_1
< systemlayback_2
< system:midi_playback_1
< system:midi_playback_2
< system:midi_playback_3
<
< sizeof 48 voices: 29952, 16 keyboards: 41352, 128 patches: 61440
<
< Voice data loaded
<
< /dev/midi: No such file or directory
< JackFifo::TimedWait name = /dev/shm/jack_fifo.default_Mx44 usec =
< 2147483647 revents 0
< SuspendRefNum error
< JackClient::Execute error name = Mx44
<
< Voice data saved
<
< Thankyou for using Mx4!
<
< Now when I run the jack gui control but do NOT start jack I can start
< mx44 fine and connect my midi controller to it by using the ALSA tab
< in the jack audio connection kit gui. runs fine but I would love to
< run it in jack for actual use. until now this hasn't been a problem.
<
< Another issue I suspect might be related is that I see no devices
< other than system in the MIDI tab when jack is started and mx44
< terminal say there is no /dev/midi directory. This is the same result
< using all 3 MIDI drivers in jack setup. so I am assuming jack isn't
< reading my MIDI devices properly? hopefully someone can direct us in
< the right direction on this as mx44 starts with jack I am wondering if
< it might be a jack MIDI issue?
<
< Nate
<
< 2009/1/9 Jarom√*r MikeŇ° <mira.mikes@seznam.cz>:
< > < Well I do know that I could only get mx44 to start with Jack. I do
< > < remember seeing that on the site but honestly everything I do
< > < audio-wise is done in jack so i never really even tried it stand alone
< > < without jack. I am actually getting the 3.0 image now and going to try
< > < it out as long as I can get it on my laptop ok. this will be a 32 bit
< > < version.
< > <
< > < As for running with jack basically I ran like any other jack app.
< > < start jack, start mx44, make the connections in the connections panel
< > < in jack, and seemed to work fine. hopefully it will still do the same
< > < this time around.
< > <
< > < nate
< > <
< > < On Fri, Jan 9, 2009 at 11:10 AM, Jarom√*r MikeŇ° <mira.mikes@seznam.cz>
< wrote:
< > < > < Well daniel it's been a while since I had it on a system but I can't
< > < > < think of a time when it wasn't stable. I believe I even installed it
< > < > < one of the early 2.0 releases from an ubuntu deb package and ran fine
< > < > < all dependencies where met as well. unfortunately right now I am
< > < > < trying to finish up a big project and not in a good position to test
< > < > < to verify but hopefully someone testing would be up to give it a try.
< > < > <
< > < >
< > < > I would like to test it ... but I am not able to run it with jack.
< > < >
< > < > This written on the websites:
< > < > http://web.comhem.se/luna/
< > < > The Mx44 software works by itself though, and with a bit of hacking you
< could
< > < probably quite easily add the missing pieces using other free sources. Or
< why
< > < not integrate it with ALSA and JACK. Mmmm ... No wait, that is already done
<
< > < .... But then DSSI maybe?
< > < >
< > < > Any advice how to run with jack?
< > < >
< > < > mira
< >
< > Hi Nate,
< >
< > when jack is running then is impossible to get run mx44 by clicking icon from
< main menu.
< > I've tried from terminal here is output:
< >
< > mira@64studio:~$ mx44
< > jack_client_new: deprecated
< > engine sample rate: 44100
< >
< > Jack nframes: 128
< >
< > client activated
< >
< > Capture ports:
< > system:capture_1
< > system:capture_2
< > Mx44:Mx44_L
< > Mx44:Mx44_R
< >
< > Playback ports:
< > systemlayback_1
< > systemlayback_2
< >
< > sizeof 48 voices: 29952, 16 keyboards: 41352, 128 patches: 61440
< >
< > Voice data loaded
< >
< >
< > Can't run in realtime! Please do (as 'root'):
< > chown root.root /usr/bin/mx44.bin && chmod 4711 /usr/bin/mx44.bin
< >
< > JackFifo::TimedWait name = /dev/shm/jack_fifo.default_Mx44 usec = 2147483647
< revents 0
< > SuspendRefNum error
< > JackClient::Execute error name = Mx44
< > /dev/midi: No such file or directory
< >
< > Voice data saved
< >
< > Thankyou for using Mx4!
< >
< > ##
< >
< > I am curious how it will behave on your system.
< > Actually my installation of 3.0 Alpha was done by upgrading from 2.1 realese
< before the iso was available.
< > Hope there is no difference.
< >
< > Thanks for your answer
< >
< > mira
< >
< > _______________________________________________
< > 64studio-devel mailing list
< > 64studio-devel@64studio.com
< > http://lists.64studio.com/mailman/listinfo/64studio-devel
< >
<
<
<
< --
< Nathan Figlar
< sonorone@gmail.com
<
<
<
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-13-2009, 09:54 AM
Daniel James
 
Default 64studio 3.0 software wishlist

Hi Jarom√*r,


Maybe the problem is because of new version of jack ... just guessing.


Yes, if the app hasn't been updated in several years. There is the same
problem with amsynth. I'd love to see both of these synths ported to LV2
instrument plugins and live on, but I don't know how feasible that would be.


Cheers!

Daniel
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 
Old 01-13-2009, 12:09 PM
Jarom√≠r MikeŇ°
 
Default 64studio 3.0 software wishlist

< Yes, if the app hasn't been updated in several years. There is the same
< problem with amsynth. I'd love to see both of these synths ported to LV2
< instrument plugins and live on, but I don't know how feasible that would be.


Yes it is sad. A lot of good work have been done and now just lie by.
Pity that I am not a coder... :-(

Cheers


mira

_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel
 

Thread Tools




All times are GMT. The time now is 12:50 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org