Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   64 Studio Developer (http://www.linux-archive.org/64-studio-developer/)
-   -   Package qsynth fails install on fresh install (http://www.linux-archive.org/64-studio-developer/191228-package-qsynth-fails-install-fresh-install.html)

"Philip Freeman" 11-10-2008 10:21 PM

Package qsynth fails install on fresh install
 
Hello,

I just installed 64studio 2.1, and I'm recieving this message when I
try to do a 'sudo apt-get dist-upgrade':

Preparing to replace qsynth 0.2.5-2 (using
.../qsynth_0.2.5-2+etch1_amd64.deb) ...
Unpacking replacement qsynth ...
dpkg: error processing
/var/cache/apt/archives/qsynth_0.2.5-2+etch1_amd64.deb (--unpack):
trying to overwrite `/usr/share/applications/qsynth.desktop', which
is also in package 64studio-themes
Errors were encountered while processing:
/var/cache/apt/archives/qsynth_0.2.5-2+etch1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


~Phil
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel

Daniel James 11-11-2008 03:17 PM

Package qsynth fails install on fresh install
 
Hi Philip,


I just installed 64studio 2.1, and I'm recieving this message when I
try to do a 'sudo apt-get dist-upgrade':

Preparing to replace qsynth 0.2.5-2 (using
.../qsynth_0.2.5-2+etch1_amd64.deb) ...
Unpacking replacement qsynth ...
dpkg: error processing
/var/cache/apt/archives/qsynth_0.2.5-2+etch1_amd64.deb (--unpack):
trying to overwrite `/usr/share/applications/qsynth.desktop', which
is also in package 64studio-themes
Errors were encountered while processing:
/var/cache/apt/archives/qsynth_0.2.5-2+etch1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


This is a known bug, see: http://64studio.com/node/678

If you look at the changelog, you'll see the only update in Debian was
to fix the desktop file name!


http://packages.debian.org/changelogs/pool/main/q/qsynth/qsynth_0.2.5-2+etch1/changelog

It's the workaround for this bug in the 64studio-themes package which
conflicts with Debian's fix.


So locking the package version for the time being is perfectly
acceptable. It's actually long overdue for a package update.


Cheers!

Daniel
_______________________________________________
64studio-devel mailing list
64studio-devel@64studio.com
http://lists.64studio.com/mailman/listinfo/64studio-devel


All times are GMT. The time now is 01:33 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.